Install on old PC with Legacy BIOS

Hi! I am installing openSUSE 15.4 on an old computer with Legacy BIOS. I see that the installer wants to create a GPT partition with a 8 MiB BIOS boot partition. Is DOS/MBR no longer supported? I remember that in the past I was able to tell the installer to create a DOS label on the new disk, but I can no longer find it in the openSUSE 15.4 installer.


I found that you can actually still change the partition label. I had to go on the top left to “Device” → “Create New Partition Table”. Then it let me select UEFI/GPT or MBR/DOS.

It looks as if you have solved this yourself. And that’s the best kind of solution.

I’ll note that using a GPT partition table should also have worked. The GPT partition table contains an MBR to keep the BIOS happy.

@gianluca44 run with gpt, better disk layout opportunities as well from a partition perspective.

Thanks! I have another question concerning the installation. I am selecting EXT4 and I need to decide between “ordered” or “journal” Data Journaling Mode. What was the default in the past for EXT4, like openSUSE 15.2 or earlier?


I haven’t been paying close attention to those changes.

I’ll note that I’m using “ordered”, which seems to be working well.

OK, thanks! It looks like that’s the default for EXT4.

Yes, it is the default.

I hopefully have a last question: wicked vs NetworkManager. It is a desktop computer connected only through eth0 either dynamic or static. In the past, I just used ifconfig, but now the choice is between wicked and NetworkManager. It seems that switching between the two can be complicated. Do either give me any advantages for a desktop PC with only one wired connection? Is wicked a big jump from ifconfig to learn it? I have never used wicked but I have NetworkManager on a laptop. Also, does wicked make booting slower? And finally, can wicked be configured through Yast like ifconfig used to be?


@gianluca44 Wicked going forward is deprecated, stick with NM, use nmtui or nmcli if no desktop, In saying that, it’s just a single text file that you can create with a text editor and drop in place (/etc/NetworkManager/system-connections/) if you know the interface name…

I tended to use ordered or journal on / (depending on how important the boxes were) and writeback on /home and other data partitions, to save some wear and tear on the HDDs.

Just my 2c

Thanks! That’s what I was thinking.

That is sad news. I use it in all my desktops, it’s a simple setup-once-in-Yast-and-forget, unlike networkmanager IME. I will leave it only if I really really must…

1 Like

There’s a third network option that gets little mention that I’ve seen: systemd-networkd, which is not usually installed by default. It cannot be managed via YaST, but it’s a breeze to setup static IP with. I have over a hundred installations using it, one using NM (installed by the person who gave the laptop to me), and zero using Wicked. Ethernet setup goes in /etc/systemd/network/.

# rpm -qa | egrep -i 'manager|wicked|network|resolv' | sort
# ls -gG /etc/systemd/network/
-rw-r--r-- 1 174 Apr 25 17:59 /etc/systemd/network/
# systemctl list-unit-files | grep -i network
dbus-org.freedesktop.network1.service  alias           -
network.service                        alias           -
systemd-network-generator.service      enabled         disabled
systemd-networkd-wait-online.service   enabled         disabled
systemd-networkd.service               enabled         disabled
systemd-networkd.socket                enabled         disabled                  static          -                     static          -                         static          -

Only systemd-networkd.socket needs enabling for static here. I just installed 15.5 afresh a few days ago, and forgot to disable the others until just now noticing my oversight.

/etc/resolv.conf is “managed” by me. I created one years ago, and copy the original wherever and whenever it’s needed. If I ever see a different timestamp on it, I know something other than me messed with it. :wink:

At installation time, you can preconfigure networking via linuxrc (installation media command line options), then switch once booted to the installed system if desired. Another option is to select “not managed” in the installer, and configure systemd-networkd once booted to the installed system.

I installed openSUSE 15.4, but after booting the keyboard is in NumLock. If I try to type “root” it types “r66t” instead. I have a ThinkPad keyboard, not a laptop, one that you attach to the desktop via USB. Some letters have numbers underneath, like a “6” under the “o”. I am able to disable the NumLock after it booted, but is there a way to disable it at boot? Thanks!

@gianluca44 There should be a BIOS setting to disable numlock.

But I never had this problem with the previous installation. Is there a setting in one of the configuration files to force NumLock off? Also, every time I restart X I need to turn off NumLock again.

I’m using KDE. There’s a setting in input devices, to set the numlock when you start KDE.

If you are using a different desktop environment, maybe check if there is a setting for that desktop.

I found some info how to turn it off also for the kernel virtual consoles:

I believe that in the previous installation it was the CapsLock that was stuck on and somehow I was able to turn it off system-wide (but I may be wrong).

# grep NUML /etc/sysconfig/keyboard

Change yours from whatever it is (probably “bios”) to “no” to configure the system value off. It’s likely booting via default value “bios”, as a result of the PC’s BIOS set to ON.

DMs and DEs generally have custom settings available that operate independently of the system setting.