Install on my laptop 200GB partition REVISITED

I can’t get into windows 10. Leap 15 boots up fine, but the grub2 menu has no Windows 10 listed.
When I try to open the Windows 10 directory in Dolphin, I get all kinds of red error messages at the top.
One of them say it is corrupted, and another indicates in an ‘unsafe’ place.
The error gave a mount command that failed, and then stated something about ‘mount -ro’.

So what did I do wrong this time?
OK, I need to get on that machine and do a fdisk or will it be gdisk for EFI, and show that here, and maybe capture that big red error message when trying to read the Win10 directory.

As far as dual booting, nothing doing at this time.
I hate going through the install over and over(three times now) , and I absolutely hate the partitioner in the installer.
I should have put in Leap 42.3 and then upgraded to 15.0.

What happens if you reinstall the bootloader via YaST - Bootloader. You don’t have to change anything, just make sure the Probe for other OS is checked. But given the messages Dolphin is giving, it might be a corrupted file system in Windows.

Some questions: did you access Windows recently? Was Windows shut down completely, i.e. with Fastboot off?

This is a pure guess.

I’m guessing that Leap 15.0 is installed for legacy booting, while Windows uses UEFI booting.

You can check with the command:

efibootmgr -v

I normally run that as root, but it worked as an ordinary user.

If you booted Leap 15.0 with UEFI booting, then the command should give some output about boot choices (probably cryptic and confusing).

If you booted with legacy booting, you will probably get an error message about “efivars”.

Don’t panic about the apparent corruption of Windows disks. That could just be a Windows annoyance (due to “fast boot”).

Be certain that Windows fast boot is off. It leaves the Windows partitions in a unclosed state which makes it impossible for Linux to read.

Once that is done run Yast - boot loader and change a value then change it back to trick the software into thinking a change has been made. Be sure that the scan for foreign OS box is checked then accept. This should get Windows into the menu and you should be able to mount the Windows partitions.

This is fdisk -l

linux-w38i:~ # fdisk -lDisk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 036073BD-199A-4EDC-9D62-78837B4C2F1E

Device         Start       End   Sectors   Size Type
/dev/sda1         64    204862    204799   100M EFI System
/dev/sda2     204863    237630     32768    16M Microsoft reserved
/dev/sda3     237631  84123647  83886017    40G Linux filesystem
/dev/sda4  420597768 975743994 555146227 264.7G Microsoft basic data
/dev/sda5  975745024 976769023   1024000   500M Windows recovery environment
/dev/sda6   84123648 241410047 157286400    75G Linux filesystem
/dev/sda7  241410048 420597767 179187720  85.5G Linux filesystem

Partition 2 does not start on physical sector boundary.
Partition 3 does not start on physical sector boundary.
Partition table entries are not in disk order.

I can’t get into windows at all. But I did check that fast boot was off, and it was.
I also believe that that the BIOS is UEFI, another thing I verified before the install.
Yes Windows was on recently, and I remember one of the messages I got was that I needed to go ‘shut it down completely’. Which I can’t do because I can’t get to it.

I could not change the size of the 100MB EFI system either before or after I partitioned. Said not allowed.

I will check the YaST thing, and nrickerts suggestion.

The only good thing to come out of this is I can at least have a working OS…lol

Also I had to install wired as I couldn’t come up with all the numbers the network portion wanted.

Yes I shut the machine down to bring it up to my router so I could do the install by Ethernet cable.

YaST boot loader Boot code section has Enable Secure Boot checked, but below that is "protective MBR flag and a box that says d’o not change’ (with ‘set’ and ‘remove’ as other options).
–And it shows GRUB2 for EFI.
–Probe is also checked.
–Windows 10 does not show up in the BootLoader Panel under Default Boot Section.
Win10 nowhere to be found, and it won’t boot.

No error with that command, and the fdisk I posted shows GPT,

Fast boot was off to the best of my knowledge. I turned it off yesterday anticipating the install today.

All partition must be a continues chunk of sectors and can expand only from the end so to change size you must have unallocated space to expand into. You can’t change size unless there is sufficient free space after the last sector in the partition.

Any possibility that Windows used some exotic file system like “Dynamic disk”?? Can you boot to Winds via the UEFI boot menu??

Making a change to YaST Boot Loader got Win10 back in the boot menu and booted up. And sure enough Fast Boot was ON! I turned it off yesterday and had not had the machine on until I stuck the USB install stick in. OH No I think Windows did start once when I wasn’t quick enough on the F12 button to boot the install USB.

You guys are a Blessing! We will see how it works going forward.
THANKS TO EVERYONE!(the star doesn’t work for you guys, but if it did…

Both system now boot, until the next Win10 Preview update at which time I will have to turn Fast Boot off again. I tried a registry hack about a year ago to stop them from changing it, but they rewrite the registry during a preview update. Dang 'em

What are the three dots when Leap 15 is booting on the UEFI machine?
The desktop has that bouncing thingy, the a green Leap logo.

Now I can start making changes and getting it set up like the desktop.

I can’t see from here. But it is probably the Plymouth splash screen running in text mode because it somehow doesn’t like your graphics.

On Mon 09 Jul 2018 01:26:03 AM CDT, Bill L wrote:

nrickert;2872872 Wrote:
> This is a pure guess.
> I’m guessing that Leap 15.0 is installed for legacy booting, while
> Windows uses UEFI booting.
> You can check with the command:
> >

> > efibootmgr -v

> >
> Don’t panic about the apparent corruption of Windows disks. That
> could just be a Windows annoyance (due to “fast boot”).

No error with that command, and the fdisk I posted shows GPT,

Fast boot was off to the best of my knowledge. I turned it off
yesterday anticipating the install today.

No error or no output?

Is the a windows efi entry in the output?

If you run the command (as root user) os-prober is there output?

I would expect out like;

efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,3002,0001,0004,0000,2001,2002,2004
Boot0000* sled-secureboot
Boot0001* Windows Boot Manager
Boot0002* opensuse-secureboot
Boot0004* openSUSE
Boot2001* EFI USB Device	RC Boot3002* Internal Hard Disk or
Solid State Disk	RC

/dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLES 15 | GNOME Shell 3.26.2 | 4.12.14-23-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

He seems to have it working (see post #10), so I guess that wasn’t the problem.

Let me put it this way, it did work, and now it doesn’t.

I had to leave my machine for a while, and when I opened the lid I had to reconnect the WiFi. Once I got that done(kdewallet is a PITA), I had to leave the machine again.

When I came back to it and opened the lid I tried to shut down.

It would not shutdown, reboot, or otherwise do anything in the power section, so I pressed the power button.

Next time I started, GRUB2 came up, and I initiated a session.

All I got was the white on black text boot stuff, a green screen with 3 small green squares, and when they went away, a black screen with a mouse cursor.

I let it set for 20 minutes and no Leap.

So, I have a machine that GRUB shows Leap, another option, and the Windows start.

All I can do now is run windows.

So I guess I will have to reinstall again when I can get it to the Ethernet connection because for some reason the WiFi the installer will not let me configure it(or I don’t know how). I know the IP, mask, dns, etc, but ipv4 box I don’t know what goes there.

Lost in Leap world again.

If you press ctrl+alt+F1 at the black screen/mouse cursor, do you get to a login prompt?

If you press the esc key when booting you should also see info on the screen, or edit the grub line (linuxefi) before booting to disable plymouth with;


You can also temporarily remove splash=silent quiet from the line as well…

Yes ctrl+alt+F1 got a login prompt.
The esc key didn’t do much that I could see.

Did the edit to grub you suggested. Still only the black screen with a mouse cursor.
I did try the ’rescue’ on the install media, but I am not smart enough to know what to do with it.