Install on dv6208nr (HP-Laptop)

after putting opensuse on my desktop to use as a server i decided i would like to give it a chance to be my primary os.

The problem that i am having is that for the life of me i cannot get it to install. First i used the same disk that i used to succesfully install on my desktop. Instal fails right away due to unable to locate repository. Then i remembered that that was just x86 and my laptop has a amd64. So i downloaded and burned the x86/64 option same result (i usualy burn dvds at 4x) so i decided to cut down to 2x (lowest option in nero) and install. This time i got further. Got past all the configuration but when it got to point to actually install after a min it comes up and fails. Unfortunatly i dont recall the error.

I remembered using cd/dvd clone in the past and remember there being an option for 1x. so i used that. Again, gets all the way to actual install after config and again fails. Might have been a message about unable to locate disk, but im not sure.

I even installed ubuntu (without any problems) redownloaded Opensuse and tried burning under linux ( figured worth a shot) again no luck.

The only way i am able to complete an install is using the Network install disk. But i dont like that it takes over 2 hours to install (i got 15mbps down and 1.5 up).

I had it installed yesterday but today i decided i wanna dual boot so i can work with embedding webpages in media player threw an .asx file for my radio show. As of now i am pushing 3 hours of install due to the efont-unicode package (23mb) is taking forever to complte. either server has network issues or its just packed as its going at an avrage speed of 4.17kb

Anyone sucessfully install OpenSUSE on a dv6208nr laptop (or simular)using standard 11.0 install dvd - not network install.

I have a fealing i can resolve this by adding a command before i start to install , but google searches and forum searches finds me nothing

I know its a amd64 chip and the drives are sata i belive, also i know under windows i need to install nvidia chipset drivers to get most things up and running