Install Nvidia driver manually!

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.

Go to Yast>Software>Software Management

Search for and install

make
gcc
kernel-source

Now download the latest Nvidia driver from here:

Unix Drivers Portal Page

At the time of the writing the latest drivers are:

NVIDIA-Linux-x86-173.14.09-pkg1.run

Download this and place the file on your desktop

Now log out and press “Ctrl+Alt+F1”

You should be in command line mode, now here log in as root

Type “root” as your user name and then your root password and press enter.

Now type “init 3” without the quotes!

Now to locate the drivers, REMEMBER we placed the driver on your accounts desktop, so type

cd /home/Your-Username/Desktop overe here “Your-Username” is the name of the account from which u downloaded the nvidia driver, so if my account name is say “snakeeyes” then I will type:

cd /home/snakeeyes/Desktop :slight_smile:

Now type

sh NVIDIA-Linux-x86-173.14.09-pkg1.run

Follow the installer and let it compile the kernel module for you.

Once everything is done and you are back in command line mode then type these commands…REMEMBER you are still logged in as “root”

nvidia-xconfig
nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

Now you can restart the machine by pressing “Ctrl+Alt+Del”

or

type in “init 5” to resume normally.

If u type init 5 then remember u r still logged in as root so press “Ctrl+Alt+F1” and you will back at the console so type in “exit” and you will log off as root and then just press

Ctrl+Alt+F7

to be back at your desktop.

Enjoy! If the next kernel update breaks your xorg then just recompile the nvidia driver. :slight_smile:

Hi,

just a few remarks about your otherwise fine tutorial.

Just today nvidia released a new (beta) nvidia driver 177.13 that for me fixed the issues with the current one so that I can run 3D accelerated video with the nvidia driver and have compiz/kwin effects.
177.13 (beta) for Linux x86/x86-64 released - nV News Forums

it is not necessary to start a new tty to go to “init 3”. One can just open a terminal in X and run “init 3” as root with the root profile sourced (su -).

starting a new tty for to do this will work also, but gives the extra minor issue that the sytem cannot be shutdown as easily since it will give you a warning that other sessions are still currently active.

imho rebooting with ctrl-alt-del is really mickeysoftish, I always prefer “init 6”, also this might pose a risk for people who have done this in a new tty and still have X running in tty7 where they might lose data.

I do not believe it is neccesary anymore to add the xcfonfig settings manually anymore.

in short it might be something like this in konsole:


$ su -
# init 3
# zypper install gcc make kernel-source
# sh /home/{USERNAME}/Desktop/NVIDIA-Linux-x86-173.14.09-pkg1.run # {select YES to have the installer configure your xorg.conf at the end}
# sax2 -r -m 0=nvidia
# init 5

cheers,
stefan

your suggestions r good as well, but the instructions I wrote r the standard instructions and similar to other distros as well for example sax2 will work in suse, but not in lets say debian and commands like nvidia-xconfig were necessary to enable compositing and stuff :slight_smile:

well I added sax2 since it is a suse site, without suse you can just skip that part at all. i mainly wanted to point out the tty stuff though.

the nvidia-xconfig settings are truly no longer neccesary, this was in the past, here a quote from the openSUSE site itself:

Compositing (3D-effects) with NVIDIA

NOTE: For openSUSE 11.0 please skip the following, just install the drivers and enable effects from simple-ccsm.

To use NVIDIA’s driver directly to run Compiz, Compiz Fusion or KDE4’s compositing effects, run the following commands and restart X (Logout and press <ctrl>-<alt>-<Backspace>). For KDE4, there exists a second HOWTO.

su -
nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

stefan

thanks for the info, but there is no harm in teaching people a bit more on how to do it manually just in case :slight_smile:

could it be that the commands aren’t necessary if u install drivers from suse repos, but I think manually they might still be necessary, what do u think?

well for me it is a mixed bag, I prefer to do anything/everything manually but it depends on the OS and the audience.

On ubuntu I just use the (great!) restricted driver manager
on Arch linux i use pacman and configure xorg.conf from the ground up with ‘vi’.
on fedora i use yum and grab it from the livna repos
on suse i use one-click-installs

imho using third party binary drivers is not great in the first place and if you must use the distros tools to keep it as standard/supported as possible and with nvidia do everything you can to stay away from the blob .run file … Especially with opensuse, things - will - break.

besides messing with the xorg.conf can be tricky stuff if you do not know you way around the CLI and vi.

stefan

ubuntu never has the latest version anyway, on one click installs u get the latest and the method I described here will work on every distro regardless of which it is and thats the point for example imagine an ubuntu user typing

sudo dpkg-reconfigure xserver-org here instead of sax2 :stuck_out_tongue:

My sax2 can’t recognize my card after compiling newest driver from nvidia :frowning: The driver that was provided with nvidia repository allowed sax2 easily to detect my card but with the compiled one, it’s not a problem because acceleration works but it’s annoying me :slight_smile: I want to see that i’m running 8800GT and not some Vesa :slight_smile:

Hi can u please post your xorg.conf?

kdesu kwrite /etc/X11/xorg.conf

If u use gnome then

gnomesu gedit /etc/X11/xorg.conf

hey i am new to linux But i am not stupid so heres my questions i have off the bat HAHA how do i open my nvidia file as a root in terminal i tried to log in to my root acc with ctrl+alt+f1 and i can type my root acc in or even my user acc name BUT it will not let me type any password with zero keys i can hit a couple that make some shape and yadayadayada but as far as type my root pw or my user pw or anything it wont let me type anything there thank you keep mt posted please iso this help to update some drivers :smiley:
by the way i am on ubuntu is far is i know hte latest version

thank you very much for helping appreciate it

when you open the terminal available at Ctrl+Alt+F1 type

root (and press enter)

then carefully type your root password (and press enter)

NOTE: as you type your root password, it will NOT show on the monitor
what you are typing…that line will continue to be BLANK (this is
not a bug, it is a security feature to keep someone behind you from
learning your root password!!)

DenverD
ps: the same is true if you enter your id (instead of that of the
superuser, root)