Install Leap on Tumbleweed?

Is it possible to install a package for Leap on Tumbleweed? None of the Tumbleweed versions of OpenBoard seem to be building in the community repos, but Leap versions are.

Thanks,
Gene

Hi
Nope, different build and different libraries… I needs updating, ping the maintainers and ask…

https://build.opensuse.org/package/users/Education/OpenBoard

Someone already commented 9 months ago at https://build.opensuse.org/package/show/Education/OpenBoard, but nothing has happened. Is there a better place to ask?

Thanks,
Gene

Hi
This user submitted a month ago: https://build.opensuse.org/request/show/942910

But that is broken, try them.

There is a missing dependency, Qt5WebKit5, in TW which is supposed to disappear in the next OpenBoard release, 1.7. I may have to wait for that update.

Thanks,
Gene

Actually, it wasn’t as simple as just installing the old version of OpenBoard from the Education repo. I also had to install libQt5WebKit5-5.212~alpha4-9.51 and libQt5WebKitWidgets5-5.212~alpha4-9.51 from https://download.opensuse.org/repositories/KDE:Qt5/openSUSE_Factory/KDE:Qt5.repo and soft link /usr/lib64/libpoppler.so.117.0.0 to /usr/lib64/libpoppler.so.114 to satisfy the runtime requirements. It seems to be working, so I think the libraries I installed and linked to are the correct ones.

Gene

Thanks for the link! I posted a comment there, and the reply pointed me to https://build.opensuse.org/package/show/home:letsfindaway:experimental/OpenBoard. That repo has a successful Tumbleweed build of the newest version, 1.7. It’s working correctly so far.

Gene