Install KDE after fail update

Hi everybody

Yesterday I updated SUSE and he stops at one moment. After a number of hours I turned off the computer. Today I get a message of KDE4 initialization error. I log in in fail-safe mode and try to resume the update, but the system says that there is no command apt-get.

What to do now?

Thanks

Hi
No apt-get in openSUSE :wink: It’s zypper ref to refresh, zypper lu to
list updates, zypper up to update. Look at man zypper.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 11:23, 1 user, load average: 0.13, 0.10, 0.08
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Sorry, I’m new in Linux and in SUSE as well.
my computer is downloading updates with zypper.

Thank you.

Zypper downloaded and installed all needed (as I though) KDE4 files. Unfortunately my computer says now that it can’t start ksmserver. I tried to find the server with the zypper, bud Zypper found nothing.

What else can I do?
Thank you.

Hi
No apology is necessary at all :slight_smile: Welcome to the world of openSUSE and
the forum.

For your next problem, I would look at creating a test user and logging
in, do you get the same issue?

If not, I would login from a VT console login (press alt+ctrl+F2),
stop the X server and just move the .kde and .kde4 directories, then
restart X and login again to see if that fixes the issue.


from the user@hostname:~>
su -

init 3
exit

mv .kde kde_backup
mv .kde4 kde4_backup

su -
init 5 && exit && exit

See how that goes… ksmserver is part of the kdebase4-workspace rpm.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.11-0.1-default
up 12:55, 1 user, load average: 0.43, 0.37, 0.28
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Command ksmserver says that NVIDIA driver can’t work without SSE2.
It seems the problem is in newly installed driver from NVIDIA site. I read about the driver problem on Ubuntu with old processor like my Duron 750. Drivers above version 100 can’t work with them. When I installed the driver I new about the problem but There wasn’ an option to select a driver’s version, and I hoped that Novell and NVIDIA companies are intelligent enough to prevent the issue. The result is sad. :?

Does anybody can suggest how to install driver’s version 96, or even to roll back to Linux nv driver?

Thank you.

From runlevel 3 (via init 3 command from a terminal), you can do

sax2 -r -m 0=nv

That should reinstall the open-source driver. Return to runlevel 5 with

init 5

to deano_ferrari

A lot of thanks. Everything is working. A am very, very appreciated.