install headaches

After putting in x86_64 live cd iso,

and watching the white text scrolling down black background,

and stopping for a moment at:

linux login: _

a gray box on a blue background pops out & says:

“Failed to start X server (YOUR GRAPHICAL INTERFACE). It is likely that it is not set up correctly…etc etc…”

anyway, much gray boxes & text…too much to copy, and after pressing all the “yes”'s…i get more white on black
ending with:

linux login: _

then gray on blue…”Trying to start the X server”…and same cycle over & over again; but no desktop.


i’m trying net install for x86_64
md5sum’s match
install went smoothly:
System Analysis
Time Zone
Desktop Selection
User Settings

Installation Overview
Perform Installation…and stops here!
progress bar moved to 1% and does not move any further. tried to click help…and abort …and nothing, including keyboard responds.

Ok, just noticed (1 hour later)

progress bar has moved to 20%…IN 1 HOUR!

Is this normal?

Do I have to leave it on all night (9:25pm here)?

Why so long? I have high speed cable?

I have never done NET install but remember it is bringing everything down off the NET. I would expect it to take some time.
The fact that the progress bar had moved to 20% does seem to indicate that it is working, so it may be just a matter of time. Though you may have to start over -with all the CLICKING you have done!

Your initial problems with the live cd are not uncommon. A dvd install gives you more options to avoid that problem (such as text mode install), though that is not always necessary.

Expect some issues with your graphics. Try and plan ahead with regard to your graphics driver - Nvidia or ATI??

…ok, it finally installed (almost) completely.

and after rebooting & selecting openSUSE 11.0 in grub

get all the similarities of the live cd and finally all the

X server error boxes and white on black ending with

linux-g5ch login: _

obviously some kind of X server & graphics card related problem.

i’m using a PNY GeForce 9600 GT

does anyone know how to fix this?

Download the driver for your card from NVidia’s site (Linux Display Driver - x86) and install. They have step-by-step instructions plus a utility to help you configure your X-Server.

you need the x86_64 driver

but it might not be so simple, because you need additional packages in order to compile. I would try this first:

at the green boot loader, pause the timer by moving the down arrow
go back to the default suse boot
lower down under the boot options is a section where there may be some text, if there is backspace it out and just type: 3
hit enter

you will have a login prompt, type:
root (enter)
then your root password (enter)

then this:
sax2 -r -m 0=vesa


If this doesn’t give you a basic display, report back.
If it does, report back too. We can walk you through it.

or check here

1-click-collection - openSUSE-Community

Sorry I missed that he was on 64 … here’s the link to those drivers:
Linux x64 (AMD64/EM64T)

Keep the URL handy … in the meantime try what caf4926 suggests.

sax2 -r -m 0=vesa

is O numeral or letter


thanks for replies.

now it wants to configure.

do that later.

(gotta go back to work now)

thanks again!

sax2 -r -m 0=vesa

is O numeral or letter

It’s a zero (numeral) :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10 SP2 i586 Kernel
up 1 day 4:58, 1 user, load average: 0.40, 0.33, 0.20
GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09


Installed (I think) nvidia drivers.


now resolution is about 640x480 or something

and is so large I can’t get main menu open (auto-hide) to change it!

stuck on desktop.

ctrl+alt+F2 to get to a console session, then login as root user;

init 3

sax2 -r -m 0=nvidia

init 5 && exit

Now if it doesn’t work for nvidia try nv instead.

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10 SP2 i586 Kernel
up 1 day 12:06, 1 user, load average: 0.44, 0.84, 0.70
GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09

Both sax2 -r -m 0=nvidia

and sax2 -r -m 0=nv

did not help but I tried vesa and got my desktop to function.

Could use a little sharper resolution but can’t seem to get the nvidia drivers to work.

Now that you’re in a graphical environment, you want to just try the Nvidia 1-click installer.

Also, for some reason I’ve had issue with SaX2 and openSUSE having issues with not properly detecting valid refresh rates for some LCD monitors occasionally. So the driver will load, but the monitor settings are off.

oh…of course…the Nvidia 1-click installer!

i never knew there was a Nvidia 1-click installer, but thanks for telling me!

can ya tell me how to find it?

Just googled & found it.

Did it & rebooted.

Doesn’t work.

One click is here:

It will start the install for you by adding the repo’s and asking for your password. But if you already installed how did you do it, did you add the repo’s already?

*enderandrew is probably correct about SaX2

Once you are sure Nvidia is installed, in a terminal type: glxinfo

Just the first part shows what you need to see
mine is here:
~> glxinfo
name of display: :0.0
display: :0 screen: 0
**direct rendering: Yes **
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

If the screen is still off
Go to Yast - Hardware - Graphics Card and Monitor
Adjust the monitor
for me its LCD 1440x900@70

your graphics card should already display in there

*NB. The VESA you are using, as per my earlier instruction to you is a basic driver. I told you to use it to just get you going. It’s not much good for regular use.

[EDIT]what do you mean it doesn’t work?? No display??

rp@linux-g5ch:~> glxinfo
name of display: :0.0
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Error: couldn’t find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
0x3a 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

go to yast - software management
using the drop box change from search to repositories

in nvidia see if you have

** nvidia-gfxG01-kmp-default
In search check for:
** kernel-source

Another option which has worked for me in the past is to download the driver from Nvidia

Save it your /home/your user name

reboot and run as level3
login as root at the prompt

cd /home/your user name

then type:
sh NVIDIA[TAB] *after typing NVIDIA if you use the [TAB] key it will auto complete
then hit return

the nvidia installer will run
just say YES to all


That doesn’t work either…after agreement and a couple of yes’s, installer says:

ERROR: Unable to find the development tool “cc” in your path; please make sure that you have the package “gcc” installed. If gcc is installed on your system, then please check that “cc” is in your PATH.

Click ok…then:

ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at Welcome to NVIDIA - World Leader in Visual Computing Technologies.

Click ok…then

black screen & command prompt.

Any advice?