Install hangs @ sata_nv driver, then no SATA found!

Is anyone successfully using an Nvidia motherboard with open Suse 11.1?

I have 2 different Nvidia motherboards and neither can install 11.1. Both hang (for a bit too long) at the sata_nv loading then later tell me there is no drive. Also using a Sata DVD player for installation if this matters, but have tried a USB DVD boot with no luck.

Boards worked fine from 10.2 to 11.0, but I cannot get 11.1 to budge.

–jumpering the SATA drive to 1.5 gigs per sec
–defaulting the motherboard bios settings

Is there any specific “must do’s” or bios settings required for Suse 11.1?

Baffled to say the least!


I’ve been using ASUS motherboards with NVidia chipsets for years (just the idea that an NVidia graphics card would do better on a mobo with NVidia chipset). No problems like this one, except once: broken harddisk controller. Are you sure, the HDD is ok?

Yes, although lately I have had chance to play with SMART in the terminal–it reported no errors–ever–on my one machine.

The likelihood of both machines blocking an install (plus, I tried Ubuntu 8.10 with the same results!) is weird. Given that both distros are troubling me, how do feel about it being a BIOS setting or a kernel problem?

Again, 11.0 runs like silk, but I’d love to tweak both machines to the latest release, etc.

i already install SLES 10 on my server.But the server always hang when the server idle or not active on holiday.For your information,the server only give DHCP service only.I install SLES 10 on IBM System X 3500,and technical support from IBM already check and he say part of hardware not faulty and health.And he give suggestion to update BIOS and firmware,the problem still same presist.:frowning:

I am using Suse 10 Enterprise and i got the same message at boot after compilng the kernel. So I booted up my last good install and went into hardware info and for my harddrive I noticed sata_nv as driver so I got kernel 2.6.20 and done make xconfig and under sata modules i choose all as modules just to be safe (not an expert) and it boots but now my usb keyboard isnt working

I finally got it to work I had to edit the .config file manually. I searched this file for USB entries and changed the =m to =y so it was compiled not as a module but into the kernel?? and it worked.

Thanks for the update, but I’m not sure exactly which config file you modified or how you would mod anything with the DVD booting.
Unless you did a live boot and modified the system in RAM before hitting the install icons…

Appreciate the help,