Install hangs on reboot

My greatest blunder ever was going with BIOS for some four years when I could have switched to UEFI earlier: Frühjahrsputz | Karl Mistelberger It was a terrible waste of time.

You may want to turn off Compatibility Support Module. Use expert partitioner and create a canonical partitioning. Host 3400G uses the same as infamous host erlangen (which serves as a reference installation for all machines I maintain):

3400G:~ # fdisk -l /dev/nvme0n1
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: Samsung SSD 950 PRO 512GB               
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: A84F222E-0177-499B-A7EA-BDA6F31E2196

Device          Start        End    Sectors   Size Type
/dev/nvme0n1p1   2048     206847     204800   100M EFI System
/dev/nvme0n1p2 206848 1000214527 1000007680 476.8G Linux filesystem
3400G:~ # 

I’d love to do that. How? :slight_smile: The only partitioner on the rescue system is “fdisk”. I don’t see a GPT option.

(Looking more carefully, it is a GPT partition table.)

and if I don’t have that “BIOS boot” partition, the partition scheme is not acceptable to the install.

I may have found my problem.

  • I must use UEFI booting because legacy booting doesn’t work

  • I cannot use UEFI booting because it is incompatible with X86_64 architecture

I’ve never set boot conditions before, so this is all new to me. My suggestion: give up on 15.4 and re-install 15.3.



Have I stumbled into a TEN-YEAR-OLD bug?

It seems that happened to someone on the 12.3 release of openSUSE, also 10 years ago:

I quit being a programmer 7 years ago. Did someone restore an old bug? This is pretty exasperating.

For the last time - you need to boot installer in EFI mode if you want to use EFI bootloader.

OK. I would be very, very happy to do that. What does that mean? How do I do that? Why can’t the installer just do whatever it is that is needed anyway?

I found another post where they seem to experience the same issue from 2015:

I’m guessing this post is made by @nrickert so maybe he has an idea?

You may read this first: Install Leap / Tumbleweed from USB Stick On Internal Disk.

Make sure you got the Manjaro Tutorial: BIOS, UEFI, MBR, GPT, GRUB, SED, LUKS.

[quote=“karlmistelberger, post:28, topic:165502, full:true”]
You may read this first: Install Leap / Tumbleweed from USB Stick On Internal Disk .
[/quote]??? I’ve been doing this for decades. The SHA sums do match.

[quote=“karlmistelberger”]Make sure you got the Manjaro Tutorial: BIOS, UEFI, MBR, GPT, GRUB, SED, LUKS .
[/quote]Having done this for so many years, it really wasn’t my expectation that going from 15.3 to 15.4 would require that I learn more than I ever wanted to about GRUB and UEFI stuff.

After having read that Happy Coders thingy, I’ve decided that I’m stupid. I understand what GRUB2 is. I understand what UEFI and EFI are. I know how the GPT table works. I’ve even known all this stuff all along. What I am having trouble learning is how to tell the installer that I want a GRUB boot loader installed into the EFI partition so that it gets loaded at boot time. That is not happening and the installer program’s hints are constrained to saying “that won’t work” and when it doesn’t say that, it creates an installation that does not work.


P.S. for my 10th install, I ignored the warning that X86_64 machines can’t handle GRUB2-EFI installations. It is correct. It hangs at the GRUB prompt.

Did you ever turn off Compatibility Support Module in the UEFI of your Computer? I do so before every install, which results in a working boot.

1 Like

Yes, that post was by me. It mentioned a problem with UEFI boot of the install media on a USB. That’s no longer a problem, so the suggested steps should not be needed.


I needed to know that that was in the BIOS config on my computer. I hunted all over the installer looking for compatibility support, with no luck. I think I found it tho:


Be back in an hour, after my 11th install.


P.S. I’ve never had to switch out of “compatibility mode” ever before. Someone added a new feature that had an effect that ought to have been pointed out in the installation. :frowning: Thank you. We’ll see what happens.

Hmm. OK. Maybe not an hour. By disabling the compatibility mode, the DVD was bypassed and I went straight into the installed system. Now all I need to do is boot into single user and fix up /home and the mount the spare partitions somewhere. BTW, disabling compat mode comes with a caveat. Scary, if you use Windows, but it is difficult for me to have a lower opinion of that OS than I already do.


I also can’t decipher that message.

RESOLVED: you cannot have a UEFI capable BIOS in compatibility mode.
That used to work okay, but things have improved.

You did catch that you have to boot the installer in EFI mode to install for EFI boot, right??? Booting installer in legacy install OS in legacy

Smooth Install

  • Turn off Compatibility Support Module and Secure Boot.
  • If issues occur temporarily disconnect all but one drive.
  • Make sure you have a backup and restore works.
  • Delete existing partitions and partition table.
  • Stay with installer defaults unless you know what you are doing.

This suggests to me your method of choosing to boot the installation medium was the actual problem. What I see seems that your BIOS was set to prioritize the DVD/USB installation medium over any internal storage, so as to conveniently boot to any attached removable medium without intervention. With the type of BIOS you have, using that prioritization you never need to see the menu that presents a boot from which media in which mode selection. What you needed to do was either change the BIOS to disable CSM as the others here have directed, or, use the BBS menu. A BBS menu appears only by use of a boot hotkey. Common ones are F12, F8, F9, F11. A BBS menu lists all possibly bootable media. For each that is bootable in UEFI mode, it is listed (at least) twice, once simply describing the medium, and at least one other with UEFI appended. By choosing a selection with UEFI appended, the installation medium would have been booted that way, thus the installation proceeded that way.

IME, CSM can be left enabled, as long as installation proceeded in UEFI mode, and your wish is to be able to boot removable legacy-boot-only media on occasion without a BIOS alteration, aka via use of the BBS menu.

To everyone who put their helpful thoughts into replies: THANK YOU!

I now understand the issues well enough not to stumble in this way again.

There is a residual complaint for the folks maintaining GRUB and Install: you can do better with your error messages. Good, helpful error messages are crucial to all good software. Had the installer said, “Your BIOS is in compatibility mode and I’m sorry, Frank, but I can’t do that install.” Alternatively, if GRUB knew that the installer would do a compatibility mode install, it could have been coded up to cope and then put up a splash warning for a few seconds telling the hapless user that there’s a problem. (This all worked in 15.3. The conflict is new to 15.4.)

Perhaps it’s just me and most folks are scouring the literature to make sure that they’re up-to-date vis-a-vis how to do stuff. Personally, I prefer to use my Linux box as an appliance that runs various pieces of software and stores my camera images. I don’t relish scouring literature to ensure I know how to do stuff that has changed incompatibly. :slight_smile: