install hangs at udev (12.3 and 13.1)

Hey all, I know there are more than a few posts about installations hanging at “starting udev” but I still haven’t been able to get by it to install on my MBP. My system specs are:

Model Name: MacBook Pro
Model Identifier: MacBookPro5,3
Processor Name: Intel Core 2 Duo
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 3 MB
Memory: 8 GB

NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3448
gMux Version: 1.8.8
Color LCD:
Display Type: LCD
Resolution: 1440 x 900
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

When I create a bootable usb and attempt to install the network version or complete version of 12.3 or 13.1 from it, I get a main menu screen that has “install, rescue, and check media” but doesn’t have any options for setting kernel parameter list items (nomodeset). I can push ‘e’ to enter an editor for some sort of file. for each of the menu options, and ‘c’ to enter a command line interface.

Does anyone have any suggestions for what to do to get this installation progressing?

I had a similar problem. I managed to get around it by selecting the “safest” kernel options from the initial install menu before doing the install. The install also choked when trying to set up grub2-efi but reverting to simple grub2 seemed to be ok.

The result was that I ended up with a lot of acpi=off apm=off … options in the standard boot. I managed to get rid of all of them, using yast>boot loader except for acpi=off which still remains. My system is now going but running at a higher temperature than it did before the upgrade.

I’m not even given the opportunity to set any kernel options. I’m not sure why my main menu is different from everyone else’s…

At the main menu – currently showing penguins disporting themselves in a winter wonderland – there are a set of Fn options at the bottom. If you choose F5 you get a choice of kernel settings including “Safe Setting” which I used and “No ACPI” which might also work.

From what you have described (use ‘e’ to edit), you have a UEFI box and in that case the install media use “grub2-efi” for booting.

That leaves your only choice for adding kernel options as using the ‘e’, then scrolling down till you find the “linux” command line, and insert your options there after the kernel path.

Do you have any suggestions for kernel options to get the installation to run?

With “nvidia” graphics, try “nomodeset”. If that works, then look into installing the “nvidia” drivers after installation is complete.

Here are the failsafe options you could try:

showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe

If you want to have as much as possible that works, and you have time to muck around, you might first try that full string…

Then, if you get the installation screen, abort the install…

Remove ONE of the options from the string and try again. If you get to the installation screen again, then you didn’t need that particular option. You can then cut off one more option & try again.

This would be a little tedious, but it would let you do the actual install with only the necessary options.

I am a painfully methodical and persistent person, so I would actually keep cutting until I have only the one or two boot options I need.

But you don’t really need to go through all that, if you would rather not.

You might also try the options:


You might also try turning APIC off, because it causes some hardware problems in some PCs (although I personally cannot recall what the command line string is for that, perhaps someone else can interject that one)

Good luck, and keep us posted.

Thanks for your help!

I succeeded in getting 12.3 installed last night. The only option that I required was “nomodeset”