Install hadoop on opensusu with YaST

I want to install hadoop from cloudera repository. I’m using opensusue 13.1 with kde.

When I click on YaST manger on the hadoop packege, I gets the following conflicts:

“Nothing provides shadow-utils needed by zookeeper”

I tried to look and install shadow-utils but I couldn’t find the correct package since I still saw the conflict message above.
Pls help me to overcome this.

Maybe you could post what/where that cloudera repo is. So that we do not have to go and search for it.

I haven’t tried to install hadoop on openSUSE, so haven’t explored support for hadoop.

But, if you don’t have special allegiance to pig/hive/solr/hadoop, I’d highly recommend you install Elaticsearch which I’ve been doing for over a year now. Elasticsearch is a “re-imagining” of hadoop from guys about 4 years ago who wanted to deliver same functionality but re-engineered from the ground up. Instead of cobbling together different projects which each require different code syntax and at least in the beginning different types of transport, Elasticsearch pieces all use JSON for expressing data structures and network transport.

Speaking strictly about Elasticsearch’s equivalent to hadoop…

  • Easy to deploy nodes.
  • No need for something like zookeeper although some have experimented with implementing. With ES, nodes automatically discover each other, do self load balancing and data distribution.

I’ve written and demo’d Elasticsearch at several local UGs and the annual SCALE conference in Los Angeles

Here are a number of <old> articles I’ve written on Elasticsearch. The instructions for installation should still be current, but the tutorials are based on older versions of ES.
Elasticsearch How-To’s on openSUSE

If move forward with Elasticsearch on openSUSE and experience any problems, I’d be happy to answer any questions. So far, I’ve not run into any deployment or use problems.

If you do decide to move forward on deploying Hadoop on openSUSE and don’t find openSUSE/SUSE packages, I’d suggest experimenting with Fedora/RH packages. I’d also be interested in your results.

TSU