Install gitkraken using community package


I am trying to install gitkraken using this repository Home:gallochri. Unfortunately, I couldn’t get it to work.

In the installation, I got an error about dependencies which is

After browsing the net, I found that libopenssl1_0_0 package provide this library and that I already have it in /usr/lib64/. So ,I have completed the installation by selecting 'break the package by ignoring some dependencies".

However, When I try to run gitkraken I got a problem related to this package. It seems like the libopenssl1_0_0 which I have is not the right file needed by gitkraken.

(process:19898): Gtk-WARNING **: 02:33:09.439: Locale not supported by C library.        Using the fallback 'C' locale.
Node started time: 1541727189706
/usr/lib64/ version `OPENSSL_1.0.1' not found (required by /usr/lib/gitkraken/resources/app.asar.unpacked/node_modules/nodegit/build/Release/nodegit.node)
Error: /usr/lib64/ version `OPENSSL_1.0.1' not found (required by /usr/lib/gitkraken/resources/app.asar.unpacked/node_modules/nodegit/build/Release/nodegit.node)
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:166:20)
    at Object.Module._extensions..node (module.js:671:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:180:18)
    at Module.load (module.js:561:32)
    at tryModuleLoad (module.js:504:12)
    at Function.Module._load (module.js:496:3)
    at Module.require (module.js:586:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/usr/lib/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:12:12)
    at Object.<anonymous> (/usr/lib/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:1145:3)

Do you have any idea how to fix this problem.

Thank you.

As said many times before: home: repos are the repos where devs/packagers can break things. Do not rely on those repos, unless you know for sure they deliver working packages. What is in those repos is not tested. The only thing one can say, is that the package builds, definitely not that the software works.

Thank you for the reply.

Even if there is a problem with the package in the home:repo. There should be a solution.

I asked my friend who had a similar problem, He told me he had to install a rpm file that doesn’t exist in opensuse default repo. Unfortunately, he doesn’t remember the name of the rpm file. But, he is sure that it’s from another distribution (centOS or Fedora).

I would also appreciate if someone know another solution even if it doesn’t require home:repos.

Thank you again.

Took a quick look at this.
Problem is that gitkraken is not open source, it’s owned by Axosoft and you only have installation options of DEB packages and TAR files.

The regular Download page is next to useless for RPM systems…
But the following is more useful

Remove your faulty install. It might not cause a problem on your machine but don’t take a chance if you can.
Then, it’s good practice to update your system before installing new software.

You can try the following which should work (Is based on the documentation to install on CentOS, RHEL and Fedora in the above link). The requirement “libXScrnSaver” should already be on your system provided by the package “libXss1” although it’s anyone’s guess without actually installing whether there is a hard coded path that might need to be addressed.

tar -xvzf gitkraken-amd64.tar.gz
sudo rsync -va --delete-after gitkraken/ /opt/GitKraken/
cd /opt/GitKraken

Should work…


Following this steps, I still got the same problem related to libcrypto.

Hello again,

I have manage to solve all the problems and get gitkraken to work.

First I got the two lib and from a ubuntu based package libssl1.0.0_1.0.2n-1ubuntu6_amd64.deb

Then, I have replaced my system similar files /usr/lib64/ and /usr/lib64/ with this Ubuntu lib that I got.

I have a question about this, can this solution lead to a problem in the future. If so if there any similar solution that doesn’t have drawbacks.

Normally, I have now to lock the package libopenssl1_0_0 in yast so that it doesn’t update and replace my new files. Is this correct?

Note: only ubuntu lib worked for me the lib form the other distribution package doesn’t seems to work.

IMO you should submit a bug to Axosoft.
Without looking at the code but based on your results,
I’m guessing that their code requires openssl 1.0.1 exactly
On TW while it appears that openssl 1.0.0 is available, you should have openssl 1.1 installed which is more current than what their code requires.

You might also submit a bug to that we probably should be packaging libssl 1.0.1 instead of or in addition to libssl 1.0.0.

An interesting try might have been to symlink openssl 1.1 to openssl 1.0.1 to see if the app would work.


Am Fri, 09 Nov 2018 01:56:03 +0000 schrieb Phenixo:

> Hello,
> I am trying to install gitkraken using this repository 'Home:gallochri ’
> ( Unfortunately, I couldn’t get it to work.

Where are the source?
I cannot find it.

So, for me gitkraken is not open source.
It is not allowed in openSUSE and the packages you have installed are not
compatible with openSUSE.
Bzw your installed packages are not generated for openSUSE.


Does this mean that the package that I have from ubuntu repo is for openssl 1.0.1. I didn’t figure that much because the package name is libssl1.0.0. So normally, it’s providing the same version as TW libopenssl1_0_0 package.
When I want to know the package version should I be looking for **package version **and not the package name? which is in this case 1.0.2n according to this website

I have another question

By symlink openssl 1.1 to openssl 1.0.1, you mean this?

sudo ln -s /usr/lib64/ /usr/lib64/
sudo ln -s /usr/lib64/ /usr/lib64/

I tried it and it didn’t work.

Yes, apparently your ubuntu libssl is version 1.0.1 which is only an incremental minor version upgrade from 1.0.0
And, if your symlink doesn’t work, then that’s a limitation of the gitkraken code.

You should submit a bug to Zxosoft, pointing out their problems running on any system that doesn’t provide that very specific libssl library.