Install from USB works, but I need autoyast help

I have followed this process
SuSE install from USB drive - openSUSE
and I now i have a working bootable and installable SLES10 images on a USB stick.

Part of what I need to this for is automated installations. I use and autoyast file that I’ve been using from network (nfs://) install for a while now, but for two days now I’ve tried to get the USB stick to work with it to no avail.

Geez, I’ve done so many tests and read so much, I don’t know where to begin to explain the problems.
Basically when the install starts, on the “Boot Options:” line, I have tried everything I could dig up on how to reference the xml file that is on the USB stick
During the install I can break from setup and actually see the xml file in a folder called /mounts/extra which is basically where it mounted /dev/sda1
but even a hard reference to that location doesn’t work. I’m wondering if this is even possible.

Can someone please shed some light on this, I can provide you with more info…


Have you got any help with this? I’m having the same problem and due to being unable to activate the NICs on the server I’m working with (they are, as yet, unsupported) I really need to be able to load an autoyast file from USB.

Here’s what I’ve figured out so far.
On the boot options like, I can specify the autoyast file with this syntax:
file:///filename.xml likewise I can specify the install location.
The big problem now is how to tell the stupid setup which disk I’m booting from NOW and which one I’ll be booting from after the install.

hopefully a smart penguin will see this post and give us some thoughts… :wink:

I figured out how to get it going properly: Unable to load autoyast file in 10.3 - openSUSE Forums