install failure Setting up encrypted dm device on /dev/sda2

openSUSE Install/Boot/Login:

I am looking for a Linux distribution with a working LTSP OOTB. LTSP-openSUSE / KIWI-LTSP looks interesting (

When I boot openSUSE-11.1-DVD-i586.iso, go through the installer, and attempt to use encrypted LVM, I get the following error dialog:



Failure occurred during following action:
Setting up encrypted dm device on /dev/sda2

System error code was: -3034

Any suggestions?



I have a similar problem. You need to fix two fstab file and crypttab. After that all will work.

There is no reference to the disk which I tried to reformat in /etc/fstab;
I deleted the reference in /etc/crypttab.

I continue to get the same error message and code 3034 and cannot reformat.

What else?

Thanks in advance, jim

On 2013-04-21 12:46, jbennett0 wrote:

> What else?
> Thanks in advance, jim

This thread started in 2009. It is surely different from your problem,
and I doubt you use 11.1, as the OP did.

So, please, start a new thread of your own with full disclosure of details.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)