install erroropensuse along win7 on dell optiplex intel i5

Hi all,
I am getting a error, “boot loader installed on a partition not less than 128 gb… system might not boot”. Hard disk is abou 450 gb on which I created 4 partitions 3 windows and one extended using GPARTED. In the extended partition I again created one ntfs block of about 100gb however win 7 resides on a 50 gb block. This was the last configuration I tried. I went ahead with the installation ignoring the message but numerous other errors began to show up like “unable to update packages”. I continued till the end of the installation only to find there was total chaos. Linux not booting. Can anybody enligten how to get around this and how to go about with proper partitioning. Win 7 will have minimum 3 partitions on my hd.
thanks and regards

Choosing to install the bootloader in MBR should solve that AFAIK.

Please open a terminal window and post output of

su -c 'fdisk -l'
(enter rootpassword)

Thanks Knurpht, I solved this by installing suse to a non allocated partition, suse itself partition it, even then the installation was not going smooth. and errors like " failed to install software" “this may lead to a broken system”. I checked all in the software options before installing. This gave me a clean install of opensuse12.1. However still struggling to add some scientific repositories.