Install error and extended partition made active?

I attempted to install Suse 11.1 after removing the partitions for Suse 11.1RC1 with a live CD. I didn’t expect any trouble, but I got some kind of fatal plasma plasma error on install and while I was searching for a camera to take its picture the install completed. When I shut down and booted windows wouldn’t boot. The message was no operating system.

I figured that the Grub was written to the MBR so I attempted to restore it with a file I had saved to a flash drive.

I used sudo dd if=bootsect.wxp of=/dev/sda bs=446 count=1 after rebooting to the liveCD. After rebooting, I still got the same error.

I then tried to use my windows disk, but the load seemed to hang after flashing something to the effect that setup is examining your configuration. I tried this twice with 2 different disks. One was a slipstreamed SP3 disk and the other was the original SP1a disk. Each had the same effect. When I booted to the Norton Ghost recovery environment the C: disk seemed intact. So I’ve been at a loss at what to do.

Back in the livecd I did a fdisk -l with the following result.
fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf868f868

Device Boot Start End Blocks Id System
/dev/sda1 1 5222 41945683+ 7 HPFS/NTFS
/dev/sda2 * 5223 7296 16659405 5 Extended
/dev/sda5 5223 5223 8001 7 HPFS/NTFS
/dev/sda6 5224 5224 8001 7 HPFS/NTFS
/dev/sda7 5225 5355 1052226 b W95 FAT32
/dev/sda8 5356 5486 1052226 82 Linux swap / Solaris
/dev/sda9 5487 5617 1052226 83 Linux
/dev/sda10 5618 5650 265041 83 Linux
/dev/sda11 5651 5781 1052226 83 Linux
/dev/sda12 5782 6304 4200966 83 Linux
/dev/sda13 6305 6794 3935893+ 83 Linux
/dev/sda14 6795 6826 257008+ 83 Linux

The last two partitions were created and formated with the Suse 11.1 install they are / and /var respectively. Looking at this I wondered if the * means that /dev/sda2 is the active partition. Surely this is a problem. If this it what it indicates then it might explain the behavior I’ve been seeing.

When I tried to install suse 11.1 its default configuration seemed to want to put GRUB on /dev/sda2 and said something about the active partition which I had trouble interpreting.
I changed the boot configuration to place grub in root but I couldn’t figure out how to ensure that it didn’t overwrite the MBR. I did uncheck and option which looked like it might overwrite the mbr. The grub menu options had entries for suse 11.1, suse 11.0, failsafe and windows.

On install I edited the partitions and setup to create the last 2 partitions and use

/dev/sda8 for swap
/dev/sda9 for /home for Suse 11.0 and 11.1
/dev/sda10 for /var for Suse 11.0
/dev/sda11 for /tmp for Suse 11.0 and 11.1
/dev/sda12 for / for Suse 11.0

I’m not sure how to change the active partition back to /dev/sda1, but I’m fairly sure that once I figure it out it will be straight forward. If someone could help me with that I’d appreciate it. What I am concerned about is what else has happened to /dev/sda2. Has it been corrupted and how do I tell? Figuring this out is not straight forward at all. Any ideas?


Ok, I managed to boot into windows by first using cfdisk /dev/sda to make the /dev/sda1 partition bootable and then using the gparted live CD to flag the /dev/sda2 not bootable. When I tried to boot after the first step I got a invalid partition table so I figured I needed to modify the extended partition which wasn’t visible in cfdisk.

I managed to get to the boot menu for suse 11.0 and login with the user and password but I didn’t get any further on the boot for suse 11.0. I had to power off after trying alt sysreq REISUB key sequence.

I then booted into Suse 11.1 live CD. I removed the /dev/sda13 and /dev/sda14 partitions first using cfdisk and then started the install. When I got to the partition table section I could tell that something was really wrong. It wanted to create 2 new partitions /dev/sda3 and /dev/sda4 for / and /home. I aborted the install. I assumed that this meant that my /dev/sda2 partition is corrupted and I need to repair it somehow. Also, I may have made matters worse by removing /dev/sda13 and /dev/sda14. I don’t know what to do at this point. I do have a picture of the screen but right now I can’t find the cable to get it from my camera to the computer. I may find it later. What can I do to repair my extended partition so I can install suse 11.1?


In the morning with a clearer head, I realized that I should have examined fdisk -l after the aborted install, and that it would be a good idea compare the results to the one I took before the install and to the one posted earlier. To make a long story short it appears that the deletion of the last 2 logical partitions with cfdisk actually changed the length of the extended partition which caused the open suse installer to propose primary partitions /dev/sda3 and /dev/sda4 for creation instead of new logical partitions /dev/sda13 and /dev/sda14. Previously I’d always deleted the logical partitions for a clean install with the gparted live CD which did not change the length of the extended partition when a logical partition was removed. My extended partition was not corrupted like I thought it was.

The original problem was that the extended partition was marked active instead of the windows partition. When I attempted the reinstall, I was very careful look for an option which might cause this to happen, and I found it under “Boot Loader Options” on the main “Boot Loader Installations” tab of the “Boot Loader Settings” window. By default, the “Set active flag in Partition Table for Boot Partition” was checked on the “Boot Loader Options” window. I didn’t uncheck it on my first attempt to install.

My original goal was to install GRUB to the root and not to the MBR and to set up the windows partition so that NTLDR would load both SUSE 11.0 and SUSE 11.1. On the main “Boot Loader Installations” tab of the “Boot Loader Settings” window, I had unchecked the “Boot from Extended Partition” option and checked the “Boot from Root Partition” because I wanted GRUB installed to the root partition. On my final successful install of suse 11.1, I unchecked the “Set active flag in Partition Table for Boot Partition” and changed to the “Boot from Root Partition” as before. Fortunately, the fatal plasma error on install which plagued my first install did not reoccur, perhaps because I didn’t explore the live installation like I did the first time. After completing the install but before shutting down the live CD installation, I followed the instructions on
Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader
to set up Windows so it would boot from to Suse 11.1 successfully.