Install different on Laptop to Desktop?

I installed 13.2 KDE Live on my Desktop yesterday. Everything worked normally, as expected. Today I installed on my Laptop. There are a number of differences I’ve noticed.

  1. The Laptop is asking me for a password when I go into Normal Terminal Mode. This doesn’t happen on my Desktop, and didn’t happen on my Laptop before the upgrade.
  2. I cannot seem to be able to completely delete my Trash Bin. Most of it got deleted, but not all.
  3. Bash is denying me permission to run my printer driver install on the Laptop. Everything was fine on the Desktop. I changed all the permissions to my users, but still the same. Even in SuperUser mode.
  4. Ghostscript & Sane weren’t installed automatically on the Desktop, but were on the Laptop.

These are just the bare-bones that I’ve noticed so far. What I’d like to do is get my Laptop to run as my Desktop is running. Namely…

  1. No password for Normal Terminal Mode.
  2. Not have Bash denying me permission on everything.
  3. To be able to run my Printer Driver Install.
  4. To delete my entire Trash Bin

Do any of these symptoms give any clues as to what I need to do to losen the reins on my Laptop?

OK. I got my printer drivers installed. So I assume bash is now not misbehaving.

I would like to remove the password from my user Terminal Mode use, not from the Super User Terminal Mode.

The strangest thing is the trash. These files appear to be the remnants from a previous install from files deleted from a USB stick. They wont delete even in Super User mode. The really weird thing is when I try to delete them, they double up the number of copies in the trash. Since they are on the /home folder, reinstalling 13.2 isnt going to help. There must be some way to delete these files?

What do you mean terminal mode??? You mean starting a terminal at boot or login or ALT-CTRL-F#? Or do you mean starting a console in the GUI? Different animals. be sure of which you speak.

I have never heard of a GUI asking for the user password to start a console (Konsole) Not even sure how to go about doing that. On the other hand it is normal to log any user into a terminal.

Trash problem seem to be an ownership problem. Who owns the files you can’t empty?

Have you ever logged into a GUI as root? DON’T!!! It can cause ownership problems (maybe like you are seeing??)

Any live whatever install is minimal and requires update to get the rest of the packages considered as the standard opneSUSE install. Myabe you doid not do the update on the Desk Top machine. For the first update I always go to Yast-update to do it since there may be recommended packages options that may not get installed from an apper update.

I mean using a Terminal Konsole (User or Super User) from the KDE Desktop. Although I wasn’t specifically referring to Dolphin, it experiences much the same problems.

When I log in as user on my Laptop, Konsole is asking me for a password. I’ve never seen that before on any installation, and would like to remove it.

Yep it an ownership problem. The files are owned by me as a user. I even set permissions to 777, and several files won’t accept the changes. But even with these permissions, I cannot delete them when logged in as root, or using Super User. I need something drastic to delete these files if even root or Super User cannot delete them.

The first thing I always do after installing KDE Live is to do an Online Update to get the rest of the installation. I did this on both my Desptop & Laptop. In both cases they didn’t install either ghostscript and/or sane completely. But after installing them separately (from the Online Update), my printer driver installed. I definitely have a different installation on my Desktop to my Laptop. Konsole doesn’t ask me for a user password on my Desktop, but does on my Laptop. Plus the aforementioned discrepancies with my ghostscript/sane installations (to name but two of the differences).

OK. As far as I can tell. It’s stuff deleted from the USB stick which cannot be deleted from the Trash.

OK. by a combination of deleting stuff from the USB stick on both the Desktop and Laptop, I’ve managed to purge my trash on my Laptop. But I’ve now managed to infect my desktop’s cache with this phenomenum. There are a number of *.trashinfo files, which I am unable to delete (among other files). But lets take one at a time :frowning: user is me, but permissions are all greyed-out, and are Can Read.

You may have to become root to remove if you don’t have permission.

Still confused about login. Let use take it step by step you are in e KDE desktop and you start a Konsole and it asks for YOUR password???

Or is it something else??

Remember we can’t look over your shoulder you have to explain it to us. And this one I have never heard of before.

Yes. That is exactly correct when starting the user Konsole not using Super User, I’m asked for a password (just like when using Super User).

Check whether there is anything in “.profile” or “.bashrc” that might cause prompting for a password.

I’m sorry but could you please tell me which folders these two files are in?

They’re in your user’s home directory

ls -l  ~/.profile
ls -l ~/.baschrc

BTW, your UID associated with a user can be got from ‘id -u <username’ eg

id - u stubble

You can check the ownership (by name) of a given file with

ls -l /path/to/file

or by UID

ls -n /path/to/file

.profile has…

test -z “$PROFILEREAD” && . /etc/profile || true

.bashrc has…

test s ~/.alias && . ~/alias || true

This is the same on my Desktop (which doesn’t need a password) and my Laptop (which needs a password).


on laptop, id -u returns


on desktop id -u returns


It’s the same username, on both

would this be because on the laptop it thinks I’m the root? How to change that?

Yes, UID 0 represents root. Are you logged in as root? On your laptop, execute


Not intentionally. I’m logging in as the user I normally login with. I also checked the security, for that user in Yast. It’s 1000. But definitely, when I use Konsole (non Super User), it tells me I’m 0, the root, on my laptop. How to fix that? It’s seems like it’s Konsole which thinks I’m the root, when I’m just a regular user.

whoami is telling me I am root also. Not surprising if id u also returns 0, and the fact that I have to login :slight_smile: But I’m definitely logged in to the Desktop as a lowly user :frowning:

Just to be clear. I’m logged into the KDE Desktop on my laptop.

If I had your laptop in front of me, I would probably find some obvious cause. But, doing it remotely via the forum, it isn’t so easy.

If you have a friend or acquaintance who is a bit more familiar with linux, I would get him or her to take a look at it in person.

Awkward…I wonder how you got a userID of 0.

First check and see who owns the files in your home directory. use ls -n to show UID and GID numbers Also be sure that the user directory is /home/stubble directory and not /root

In yast you can change the userID to 1000 which is the normal first user ID This may change the ownership of the associated home but may not fix ALL the files in home so some may end up owned by root which may cause problems booting to desktop.

Running as root can cause damage in all sorts of surprising places. If it was me I’d be inclined to reinstall since this is a new install. Backup anything that you really need first.