Install Broadcom 4318 in openSUSE 11

Sorry for my english, I speak spanish

  1. Open a terminal and login as root, then run:

lspci | grep Broadcom

results would be something like this:

05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

  1. Download the driver:

RapidShare: Easy Filehosting

  1. In terminal run (as root):

modprobe -r b43
modprobe -r b44
modprobe -r b43legacy
modprobe -r ssb

  1. Install ndiswrapper from openSUSE dvd

  2. Install the driver (in a terminal as root):

ndiswrapper -i /(driver’s folder)/bcmwl5.inf
ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4318) present (alternate driver: ssb)
ndiswrapper -m
modprobe ndiswrapper

  1. Load ndiswrapper on boot system
  • edit /etc/sysconfig/kernel

    add “ndiswrapper” in the section MODULES_LOADED_ON_BOOT="" —>MODULES_LOADED_ON_BOOT=“ndiswrapper”

save and exit

-edit /etc/rc.d/boot.local

add at the end of the file the following lines :
modprobe -r b44
modprobe -r b43
modprobe -r b43legacy
modprobe -r ssb
modprobe -r ndiswrapper
modprobe ndiswrapper
modprobe b44

exit 0

save and exit

restart de system and wifi is ready to be used

it’s all

bye bye, from Argentina…joaco :wink:

jnigro wrote:
> Sorry for my english, I speak spanish
>
> 1) Open a terminal and login as root, then run:
>
> lspci | grep Broadcom
>
> results would be something like this:
>
> 05:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One
> 54g] 802.11g Wireless LAN Controller (rev 02)
>
> 2) Download the driver:
>
> ‘RapidShare: Easy Filehosting’
> (http://rapidshare.com/files/72536890/SP36684A.zip.html)
>
> 3) In terminal run (as root):
>
> modprobe -r b43
> modprobe -r b44
> modprobe -r b43legacy
> modprobe -r ssb
>
> 4) Install ndiswrapper from openSUSE dvd
>
> 5) Install the driver (in a terminal as root):
>
> ndiswrapper -i /(driver’s folder)/bcmwl5.inf
> ndiswrapper -l
> bcmwl5 : driver installed
> device (14E4:4318) present (alternate driver: ssb)
> ndiswrapper -m
> modprobe ndiswrapper
>
> 6) Load ndiswrapper on boot system
>
> - edit /etc/sysconfig/kernel
>
> add “ndiswrapper” in the section MODULES_LOADED_ON_BOOT=""
> —>MODULES_LOADED_ON_BOOT=“ndiswrapper”
>
> save and exit
>
> -edit /etc/rc.d/boot.local
>
> add at the end of the file the following lines :
> modprobe -r b44
> modprobe -r b43
> modprobe -r b43legacy
> modprobe -r ssb
> modprobe -r ndiswrapper
> modprobe ndiswrapper
> modprobe b44
>
> exit 0
>
> save and exit
>
> restart de system and wifi is ready to be used
>

Yes, this method will work, but be aware of the consequences. First of
all, you are running a Windows driver with no protection against
errors in that driver. What would be a Blue Screen of Death in Windows
is a Linux crash. Secondly, loading that driver sets the “tainted”
flag, which means that no kernel developer will even look at any other
problem you might have.

A better method is to have a wired network connection, launch a
console terminal and enter the following command:

sudo /usr/sbin/install_bcm43xx_firmware

This script will install the firmware necessary to use the open-source
driver. Once that is done, your wireless will work without tainting
your kernel.

Larry

Ok, but I don’t have a wired connection

I find my solution only this way

thank for explanation

jnigro wrote:
> Ok, but I don’t have a wired connection
>
> I find my solution only this way

I cannot find your previous posting. Does your wireless now work, or
do you still need help? If so, does your system dual boot Windows?
Does your wireless work that way?

Larry

Hi Larry, this is my first post.

My wireless is working perfectly

I use dual boot, opensuse and windows

my problem is that I connect my laptop to the Internet through an public AP, therefore could not use internet until load my wireless
then I invent this method of installation to use my wireless, when you not have a wired connection to use the script

the driver+ndiswrapper is perfectly stable, and is working ok

I come from ubuntu and there also used ndiswrapper. I never had a problem

this tutorial can serve to people without internet conection

bye, bye …from Argentina, joaco;)

I have been tryin for the last 40 hours to get mine working and I have tried both methods. It lights up and recognizes it, but won’t connect to a router. Any Ideas

thrgadgetman wrote:
> I have been tryin for the last 40 hours to get mine working and I have
> tried both methods. It lights up and recognizes it, but won’t connect
> to a router. Any Ideas

You should not hijack a thread. Please start a new one.

When you do, please open a terminal and post the output of the command

dmesg | egrep “ssb|b43”

I have created a self extracting archive which you can download here http://rapidshare.com/files/428439289/broadcom-wifi-driver.sh

After downloading,


su -
sh broadcom-wifi-driver.sh

That’s it. You do not need to have Internet connection, the self-extracting file (broadcom-wifi-driver.sh) contains everything you need.

On 11/02/2010 02:36 AM, the gripmaster wrote:
>
> I have created a self extracting archive which you can download here
> url removed
>
> After downloading,
>
>
> Code:
> --------------------
>
> su -
> sh broadcom-wifi-driver.sh
>
> --------------------
>
>
> That’s it. You do not need to have Internet connection, the
> self-extracting file (broadcom-wifi-driver.sh) contains everything you
> need.

I applaud your efforts; however, did you obtain the right to redistribute the
Broadcom driver files from openWRT or Broadcom? If not, please remove this code
immediately. As far as I know, neither you nor anyone else has the right to
redistribute this firmware. That is the reason the setup is the way it is. If I
am wrong, please post the URL of the document granting this license.

At the moment, we of the wireless community are trying to convince Broadcom that
it is in their best interests to grant a redistribution license so that the
firmware can be added to the linux-firmware package. Any unauthorized
redistribution of their intellectual property does not help our cause.

Thanks for pointing that out. I could not find an edit button to edit my post. And I have also lost the link to delete it from rapidshare. Anyway I have reported my own post to be removed by the admins.

Post removed at request of the_gripmaster

Thanks for removing.