Install / Boot 11.2 kernel hang


I’m unable to boot openSUSE 11.2 after the update from 11.1.
Previous version worked very well, and the kernel don’t have any special parameter to boot… With the 11.2 kernel (default and desktop 64 bit version) its impossible to boot. Black screen after loading the kernel image.

The only way to go ahead is to boot with acpi=off edd=off noapic parameters, but when loading the aacraid module (there’s an Adaptec 3805 in the system) shows an error about an scsi reset issued by the Adaptec card and then kernel crash.

The update was done with zypper dup, without problems. But I can’t boot from the 11.2 install DVD, with the same symptoms, to do a clean install.

Seems I’m stuck with an unbootable openSUSE system… Any clue about these issues?


Do you actually HAVE an Adaptec card? If not, you could blacklist it.

Try picking the videomode=VESA from the options when booting from the install DVD. Might be a hardware problem as well, since you have the same problems booting from the DVD.

Different video options, same result… >:(

The installation stops at Starting udev… After some time, ends with a kernel backtrace: a lot of really scaring messsages, ending with “child_rip+0x0a/0x20”

The openSUSE 11.1 install runs fine, I’m downgrading now to 11.1…

Don’t know if this has anything to do the problem, but did you check the checksum on the iso when you burned the disc?

I just asked because while testing one the 11.2 milestones, I had a similar situation (the boot stopped at the hardware detection phase and started spewing strange messages) and it turned out the image was corrupted.

Yes, the DVD was verified. In fact, the update from 11.1 to 11.2 was done without the DVD. Directly with zypper dup and online repositories. I can’t start the install from DVD media.

But once the update was done correctly, the system refused to boot. Exact same symptoms and errors from online kernel and DVD install kernel.

Now, I’ve finished the downgrade to 11.1, without problem. For me, the 11.2 kernel has changed something that causes severe problems in a perfectly stable system. OpenSUSE 11.1 and Win XP are running ok and stable.

There’s a way to debug the boot process to know more about the origin of the problem?

I’m posting my hardware config, maybe someone has similar problems related to specific hardware components:

Gigabyte GA-MA790FX-DQ6 board
AMD X2 5000+ processor
4 GB RAM DDR2 800
Adaptec 3805 SAS/SATA RAID card with 4 SATA HDD RAID5
NVIDIA 9800GTX card

This seems to be basically the same problem as described on bugzilla as bug 54801

There seems to be an acpi problem with 11.2 and some Gigabyte mainboards. I have very similar hardware as listed in the last post.

As described in bugzilla I managed to boot into the 11.2 installation system with kernel parameter “acpi=ht”. You might try that with your upgraded system as well.

Feedback would be welcome.

If I have some time next weekend, I’ll install 11.2 with “acpi=ht” on a separate partition and investigate further.

Typo correction: It is bug #548108 in bugzilla

I installed openSUSE 11.2 on a separate partition of my computer and did some investigations.

  • Also the installed system only boots with “acpi=ht”
  • During boot with “acpi=ht” I get some scary messages and the boot process hangs at “Creating devices” until timeout - see bugzilla bug 559048
  • Cannot configure SCSI scanner, no detection by YaST, sane-find-printer hangs, see bugzilla bug 559046
    -Shutdown does not terminate regularly, disks are not properly unmounted, see bugzilla bug 559049

With the above experience I decide not to switch to 11.2 until the problem is solved. 11.2 is basically unusable for me in the current status.

I repeated everything that failed on 11.2 on my installed 11.1 system on the same computer - it worked without any problem, a perfectly stable system.

See more details in bugzilla - bug 548108

I’ve just added some test in your bugs.

In my case installing the kernel-vanilla (those without suse patches ) allow me to boot normally.

But many thing is missing.

Hi there,
I faced the same problem on installing the 11.2 64bit on an Intel T5800 processor, 4GB RAM on samsung R610, I had the DVD from a retailer and did not download it myself.
when installing and after loading the kernel the system restart directly,I could bypass that by setting the ACPI to “NO” on the installation menu and could continue the installation and the system worked fine in every aspect except when switching from AC to battery and vice versa; then it restart ! also it does not power off unless I shut it down from the power bottom.

I had the same system with the same configuration worked fine with 11.1, it is 11.2 default kernel problem.

Latest default kernel from SUSE Factory works with ACPI (same hardware and BIOS settings as with the non working installation kernel):

uname -a
Linux linux-3yrb 2.6.32-41-default #1 SMP 2009-12-11 11:05:24 -0500 x86_64 x86_64 x86_64 GNU/Linux

more details in bugzilla #548108 and #557586

In the meantime I got my system to work with ACPI by a BIOS upgrade: MB GA-MA770-Ds3 rev.1 from BIOS version F6 to F7

This seems to be a known problem, please look at
Bugs:Most Annoying Bugs 11.2 - openSUSE