Install 11.1RC1 messed up 11.0 install -- help

I loaded opensuse 11.1 RC1 live CD last night to see how it worked. I got stuck configuring the network card. It seemed that the network switch was off and wouldn’t turn on so that even though the firmware was installed I couldn’t get past that issue. So I decided to go ahead and install a second copy of opensuse on the machine, so that I would be about to reconfigure and reboot.

I have a copy of opensuse 11.0. I configured 2 new partitions 3.75GB for the root, 256MB for /var. I configured it to use the existing 1GB swap, the existing 1GB /temp, and the existing 1GB /home. I gave it a new userid which was different from the one I used in 11.0. I also told it to not install a bootloader, because I wanted to configure GRUB on opensuse 11.0 to load the 11.1RC1. I currently use NTLDR to load either windows or opensuse 11.0 and I figured that I would be able to boot to opensuse 11.0 and configure GRUB to load 11.1.

When time came to boot out of the live CD I booted to windows and then booted to opensuse 11.0. The boot to opensuse 11.0 failed with these messages as the last 3 lines.

Code: Bad EIP value
EIP: <000000a1>] 0xa1 SS:ESP 0068:c0481d44
Kernel panic - not syncing : Fatal exception in interrupt.

Why would the 11.0 be affected by an install to a completely separate system partition.

I’m a stumped as what to do next. It seems that 11.0 has been corrupted somehow and that 11.1 is not bootable as a result because I can’t get to GRUB.

I verified the CD media before I loaded the live CD.

Any suggestions short of reinstalling both systems?

Leslie

Hi Leslie,

Bad EIP value messages often indicate a mismatch between your kernel and hardware.

In this case, but not sure about this… it could have to do with having a different/shifted partition layout.

I’ve never used the NTLDR to load a non Windows OS (as its always given me issues)… so I can’t help you with that configuration.

A first thing whould be to boot with the LiveCD.
if you could post the output of ’ fdisk -l ’ we can see what your partition layout looks like.
You can also check if the openSUSE 11.0 partition is ok.

Is Windows your main OS? I’m thinking it might be a good time to let GRUB be the bootmanager on your system. With GRUB you have more control how to boot what (as also more troubleshooting options). Switching to GRUB can mean some downtime from Windows, just until you’ve set the right options in GRUB.

-Willem

I booted to my opensuse 11.0 live cd. (It took 2 times because I first had my SD card in the notebook and it hung on the boot. I saw this before with 11.0 live cd but I didn’t see it with 11.1 RC live cd !)

Here are some listings.

linux:/home/linux # fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf868f868

Device Boot Start End Blocks Id System
/dev/sda1 * 1 5222 41945683+ 7 HPFS/NTFS
/dev/sda2 5223 7296 16659405 5 Extended
/dev/sda5 5223 5223 8001 7 HPFS/NTFS
/dev/sda6 5224 5224 8001 7 HPFS/NTFS
/dev/sda7 5225 5355 1052226 b W95 FAT32
/dev/sda8 5356 5486 1052226 82 Linux swap / Solaris
/dev/sda9 5487 5617 1052226 83 Linux
/dev/sda10 5618 5650 265041 83 Linux
/dev/sda11 5651 5781 1052226 83 Linux
/dev/sda12 5782 6304 4200966 83 Linux
/dev/sda13 6305 6794 3935893+ 83 Linux
/dev/sda14 6795 6826 257008+ 83 Linux

Disk /dev/sdb: 501 MB, 501219328 bytes
255 heads, 63 sectors/track, 60 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000358a0

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 61 489440+ e W95 FAT16 (LBA)

This looks right. I have 3 extended windows partitions. They are basically place holders for when I reinstall windows (another project), so I won’t mess up the linux partition numbering.

/dev/sda9 is /home
/dev/sda10 is /var for opensuse 11.0
/dev/sda11 is /temp
/dev/sda12 is / for opensuse 11.0
/dev/sda13 is / for opensuse 11.1
/dev/sda14 is /var for opensuse 11.1

I mounted /dev/sda9, /dev/sda12, /dev/sda13 and did some ls -l and listings of files. The directory and file structure seems ok.

Here are listings for the grub menu and device files on opensuse 11.0.
linux:/ # cat /suse11/boot/grub/menu.lst

Modified by YaST2. Last modification on Thu Nov 13 13:17:22 CST 2008

default 0
timeout 8
gfxmenu (hd0,11)/boot/message

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - 2.6.25.18-0.2
root (hd0,11)
kernel /boot/vmlinuz-2.6.25.18-0.2-default root=/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part12 resume=/dev/sda8 splash=silent showoptsvga=0x317
initrd /boot/initrd-2.6.25.18-0.2-default

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.0 - 2.6.25.18-0.2
root (hd0,11)
kernel /boot/vmlinuz-2.6.25.18-0.2-default root=/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part12 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe vga=0x317
initrd /boot/initrd-2.6.25.18-0.2-default

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,11)
chainloader (hd0,0)+1
linux:/ # cat /suse11/boot/grub/device.map
(hd0) /dev/sda
(hd1) /dev/sdb

Here is a directory listing for grub on opensuse 11.1.

linux:/ # ls -l /susenew/boot/grub
total 208
-rw-r–r-- 1 root root 8660 2008-11-22 00:20 e2fs_stage1_5
-rw-r–r-- 1 root root 7844 2008-11-22 00:20 fat_stage1_5
-rw-r–r-- 1 root root 7120 2008-11-22 00:20 ffs_stage1_5
-rw-r–r-- 1 root root 7116 2008-11-22 00:20 iso9660_stage1_5
-rw-r–r-- 1 root root 8700 2008-11-22 00:20 jfs_stage1_5
-rw-r–r-- 1 root root 7348 2008-11-22 00:20 minix_stage1_5
-rw-r–r-- 1 root root 9744 2008-11-22 00:20 reiserfs_stage1_5
-rw-r–r-- 1 root root 512 2008-11-22 00:20 stage1
-rw-r–r-- 1 root root 103726 2008-11-26 10:52 stage2
-rw-r–r-- 1 root root 7380 2008-11-22 00:20 ufs2_stage1_5
-rw-r–r-- 1 root root 6720 2008-11-22 00:20 vstafs_stage1_5
-rw-r–r-- 1 root root 9544 2008-11-22 00:20 xfs_stage1_5
linux:/ #

I don’t know what else to look at.

Windows is my main system, but I can temporarily write over the mbr and put it back. I have a copy of it saved. I’ve been happy with using the ntldr for windows and opensuse but I wondered about grub and adding a second (and third) linux and whether to use the same method where I overwrote the windows mbr and saved a copy of the mbr for the second linux and referenced it in the linux boot.ini file. This would I think give me grub menus for all the linux systems independent of each other. I tried to do something different. I wanted to use the main grub system and have it refer to each linux system while referring to the main linux system in ntldr. That was what I was trying to do. I still need to figure that out, but right now I’d like to get both linux installations operational again.

I installed linux as a learning experience, to see how well they worked. It seems that when I encounter an issue I usually have to solve several before the original can be fixed if at all.

Leslie

Thanks for the elaborate answer!

& Wow… that are allot of partitions! :slight_smile:

The partitions seem to match with your grub’s menu.1st configuration… so a partition shift does not seem to be the suspect.

Looking at your partitions the thought now crosses my mind… how did you shrink the openSUSE 11.0 partition? Or didn’t you shrink it??
You could run a fsck from the LiveCD to see if the filesystem is consistent.


/dev/sda9 is /home
/dev/sda10 is /var for opensuse 11.0
/dev/sda11 is /temp
/dev/sda12 is / for opensuse 11.0
/dev/sda13 is / for opensuse 11.1
/dev/sda14 is /var for opensuse 11.1
<snip>

I don’t know what else to look at.

Out of interest… why are you creating partitions for the /var and /temp directories? Seems this makes it overly complex.

<snip>

I wanted to use the main grub system and have it refer to each linux system while referring to the main linux system in ntldr. That was what I was trying to do. I still need to figure that out, but right now I’d like to get both linux installations operational again.

Seems like that plan could work… but with my inexperience with using NTLDR as bootloader, I wouldn’t know if this is causing the issue. I would think if the setup worked with 11.0 it should also work with 11.0 and 11.1 combined.

As a suggestion, it might be a better option to use a special bootloader application to manage all these partitions.

  • BootIt NG (Terrabyte) has been my trusty tool for quite a while now. You can set it up so each system only sees it’s own (or shared) partitions. This lets me give every system primary partitions keeping boot problems to a minimum.
    Another nice feature is that you can image and restore from within your boot manager. Makes testing all the more simple.

I installed linux as a learning experience, to see how well they worked. It seems that when I encounter an issue I usually have to solve several before the original can be fixed if at all.

You’ll probablt have a smoother ride by starting with a dedicated system (or a more simplistic partition setup). Linux does have a learning curve… My experience as of 10.3, is that less issues pop up and the biggest challenge is checking if your hardware is properly supported. The setup is getting simpler with each new version.

These forums are generally a good place to drop you questions… I think you’ll see that the more you get into Linux the prettier it gets :wink:

Now to get you booting again! I’d first suggest to check the openSUSE 11.0 partition for errors.
After try swapping the MBR code so GRUB gets boot priority.

Wishing you luck,
Wj

I used the windows bootloader for my multiboot arrangement. Grub has a nasty habit of occassionally stepping on the windows boot sector and rendering the mbr unusable. It’s happened to me (coronary arrest) and i got to learn how to use the fixmbr command from the winxp install disk… :).
My situation is somewhat complicated since my windows environment is dualboot win98se/winxp with lots of partitions formatted in FAT32 (for compatibility with win98) and some ntfs in addition. There is an excellent how-to at swerdna’s site… Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader. for those so inclined.

I did not change any of the existing partitions. I had about 8 GB of free space of which I used about 4GB for the 2 new partitions used for opensuse 11.1 / and /var.

I had a couple of reasons to partition linux that way. One is that I had very limited space (I also wanted to eventually try 3 different linuxes) and a potential need for a fairly large /tmp. I wanted something large enough for temp files in burning CDs and making ISOs and other uses I didn’t know about. I wanted to share some partitions that would enable me to reduce the size of each root partitions. Also I understood that if /tmp or /var fills up the root partition then the system would crash. If they were on separate partitions then the system doesn’t crash and you have time and space to recover. I actually experienced this while I was trying to get the wireless internet working. A log in /var filled up the remaining unused space of the 256MB so that my system became virtually unusable. I was however able to find the log file, rename the log file, restart the system/subsystem (I forget how), delete the file and have the system work again. Simply rebooting did not work. After that I decided it was worth the trouble to have a /var partition for each linux I installed. I had initially decided to try it with one. A third reason is related to backups. Although I don’t have a backup of these partitions yet, I wanted to be able to back them up without copying a lot of temp space. Separating /tmp from the root helps with this. I’m not so sure about /var.

fstab for suse 11.0
cat /suse11/etc/fstab
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part10 /var ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part11 /tmp ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part12 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part8 none swap defaults 0 0
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part9 /home ext3 defaults 1 2
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part5 /windows/P ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part6 /windows/U ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_FUJITSU_MHT2060_NP0RT44279S5-part7 /windows/S vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 00
sysfs /sys sysfs noauto 00
debugfs /sys/kernel/debug debugfs noauto 00
devpts /dev/pts devpts mode=0620,gid=5 00

fstab for suse 11.1
cat /susenew/etc/fstab
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part8 swap swap defaults 0 0
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part13 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part9 /home ext3 defaults 1 2
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part11 /tmp ext3 defaults 1 2
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part14 /var ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part5 /windows/P ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part7 /windows/S vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/ata-FUJITSU_MHT2060AH_NP0RT44279S5-part6 /windows/U ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 00
sysfs /sys sysfs noauto 00
debugfs /sys/kernel/debug debugfs noauto 00
devpts /dev/pts devpts mode=0620,gid=5 00

I ran fsck on partition 9, 10, 12, 13, 14 and the result seemed to be clean.

I wrote all this and then decided to attempt a reboot into opensuse 11.0 before overwriting the MBR. I wondered if there was an issue with the partition table either in the linux code on windows or in opensuse 11.0 that couldn’t handle the new partitions added. I don’t understand why that might be but it was really the only thing I could figure that was external to opensuse 11.0 that might give a panic attack. When I rebooted it worked. I’m having trouble accounting for this. Either I do have a hardware problem or it is related to the addition of two partitions on boot causing a problem which was corrected somehow.

So now I need to setup grub to boot opensuse 11.1 from opensuse 11.0. I am concerned that I made a poor choice when I installed opensuse 11.0 but I will look at that in the morning. I’m too tired to work any more on it tonight. It is nice to have opensuse 11.0 up and running again.

I looked at the Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader site Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader.
He uses bootloader installed on root instead of the MBR like I used. But it may work better than what I had planned. I’ll need to try out the options once I get opensuse 11.1 to actually boot.

Leslie

Could this be what was causing your initial issue?

I must say you are very thorough! There’s been good thought about the way you have set up the partitions.
For myself, I’d rather have some more space for two systems then try to fit three on. But I’m a space munger (somewhat like the cookie monster) with all my downloads and all… :wink:

Using the included backup utility in openSUSE, even though it’s a ‘simple’ utility, you can exclude all those directories you don’t want to include. Could be an option.

Hope you have (had) a nice rest as these things can be a true energy drain!

Members mingus725 & swerdna are two I know of that are quite handy in setting up different boot scenarios.

I think you’d get a good response by opening a new post in the boot section asking for support on multiboot.
They might give you some new insights on what you want to achieve.

Wishing you luck,
Wj

Originally Posted by TexasDayLily View Post

[QUOTE]“I booted to my opensuse 11.0 live cd. (It took 2 times because I first had my SD card in the notebook and it hung on the boot. I saw this before with 11.0 live cd but I didn’t see it with 11.1 RC live cd !)”

Could this be what was causing your initial issue?[/QUOTE]

I did have the SD card in the machine when I first attempted to boot suse 11.0 after installing 11.1 and before completing the install boot to 11.1, but I had had that card in the machine when booting suse 11.0 before with no problem. Only the 11.0 liveCD seems to cause a problem.

Once I loaded suse 11.0 I edited the grub file with the following lines.

title OpenSUSE 11.1 RC1
    root (hd0,12)
    kernel (hd0,12)/boot/vmlinuz-2.6.27.7-4-default root=/dev/sda13 resume=/dev/sda8 splash=verbose showopts vga=0x317
    initrd (hd0,12)/boot/initrd-2.6.27.7-4-default

These lines allowed me to access the installation even though I had not installed the grub bootloader in the root or the MBR. At this point I think that loading it in the root and copying the boot sector into windows and adding code to the boot.ini file is probably a good thing to try, but I’ve been able to boot multiple times.

Thanks for your help.

Leslie

Hi Leslie,

Glad you’ve been able to set it up now, you’ve been the brains here… not me!
Hope you now get to enjoy the fruits of your labour!

Cheers,
Wj