Instaling Eclipse 3.6

Hi everybody,
I’m new in openSuse and the Linux world. So forgive me if I am writing this thread in the wrong forum.
I downloaded the Eclipse Helios and unzipped it. But I can run it! When I try to open it, nothing happens! Not even a error message! I looked in google and other foruns to know how install Eclipse, but found nothing useful. Can any one help me please?

From a terminal when you type eclipse, what are you getting?

What version of openSUSE are you using and you can install Eclipse from yast, it’s in the openSUSE Oss repo.

Oh and Welcome.

Create a desktop shortcut to it, else open a terminal in the directory
it’s unzipped too and run;


There is already a desktop entry, but you need to modify the Exec and
Icon entries to add the full paths for example on my desktop it’s;

#!/usr/bin/env xdg-open
[Desktop Entry]
GenericName=Eclipse IDE

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 23:15, 3 users, load average: 0.16, 0.13, 0.10
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21

It gives the following message:

If ‘eclipse’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf eclipse

When I write cnf eclipse comes this:

The program ‘eclipse’ can be found in the following package:

  • eclipse path: /usr/bin/eclipse, repository: zypp (repo-oss) ]

Try installing with:
zypper install eclipse

But if I write this last command, it will install the Eclipse 3.4, but I want the 3.6. How do I configure the openSuse so that when I type ‘eclipse’ it runs the Eclipse 3.6?

On Mon, 15 Nov 2010 21:36:02 +0530, Djonggee
<> wrote:

> But if I write this last command, it will install the Eclipse 3.4, but
> I want the 3.6. How do I configure the openSuse so that when I type
> ‘eclipse’ it runs the Eclipse 3.6?

it’s a while ago that i tried eclipse, but if i remember correctly, you
‘install’ it by uncompressing the archive and keeping it somewhere under
your home dir. obviously the system doesn’t know about this. to start
eclipse, you’ll have to include the path to the application, something
like “~/<your eclipse dir.>/eclipse”.

you can specify this in a desktop or menu shortcut, or you can place a
symlink into /usr/bin (that’s one of the locations the system looks for
executable programs). in a root terminal, type

ln -s /home/<your user name>/<your eclipse dir.>/eclipse /usr/bin/eclipse


Thanks everybody.

I made just like phill said, but now it is returning this message:

bash: /usr/bin/eclipse: cannot execute binary file

I don’t have any clue about what is happening… :frowning:

So did you just extract the eclipse in your home directory? if so what happens if you run;


If it’ doesn’t work. Delete the link you created in /usr/bin and delete the eclipse directory and start again…

Unpack the eclipse and browse into the eclipse directory, the directory should be like this;

malcolml@oscar:/data2/eclipse/eclipse$ ls -la
total 700
drwxrwsr-x  9 malcolml users   4096 2010-11-14 11:30 .
drwxr-xr-x  3 malcolml users   4096 2010-10-03 18:56 ..
drwxr-sr-x  2 malcolml users   4096 2010-10-10 00:06 about_files
-rw-r--r--  1 malcolml users  18909 2010-09-09 08:23 about.html
-rw-rw-r--  1 malcolml users 135038 2010-10-10 00:37 artifacts.xml
drwxrwsr-x  9 malcolml users   4096 2010-11-14 11:30 configuration
drwxrwsr-x  2 malcolml users   4096 2010-06-17 10:35 dropins
-rwxr-xr-x  1 malcolml users  71162 2010-08-10 16:48 eclipse
-rw-rw-r--  1 malcolml users    420 2010-10-10 00:38 eclipse.ini
-rw-r--r--  1 malcolml users     59 2010-07-29 10:37 .eclipseproduct
-rw-r--r--  1 malcolml users  16536 2005-02-25 18:53 epl-v10.html
drwxrwsr-x 41 malcolml users  12288 2010-10-10 00:37 features
-rw-r--r--  1 malcolml users   9022 2006-12-11 11:04 icon.xpm
-rwxr-xr-x  1 malcolml users 335360 2006-12-11 11:04
-rw-r--r--  1 malcolml users   9051 2010-04-27 15:23 notice.html
drwxrwsr-x  5 malcolml users   4096 2010-06-17 10:33 p2
drwxrwsr-x 50 malcolml users  45056 2010-10-10 00:37 plugins
drwxr-sr-x  2 malcolml users   4096 2010-10-10 00:06 readme

Djonggee, do you have a certain reason to install version 3.6?
If you don’t wish to turn your computer into a nuclear polygon you’d better install packages from official repositories. Later you may forget that you installed a program by an alternative mean and install its’ new version above the old one. You can get two versions of the same program simultaneously, both going astrade.
I experienced that twice or thrice and, stupid of me, searched for the problems, origin very long :slight_smile:

Hi there,
Problem solved! Not by me, but by a friend of mine. He did this:

  1. Uninstalled and delete everything that has to do with Eclipse;
  2. Installed Eclipse 3.4 from the repository;
  3. Made a save-copy from the file “eclipse” that were created in the directory /usr/bin;
  4. Uninstalled the Eclipse 3.4;
  5. Unzipped the Eclipse 3.6 files into the folder /usr/share/eclipse;
  6. Copied the file “eclipse” into the directory /usr/bin.

@sunders I want to use Eclipse 3.6 because I use it in the company where I work. And I want to compare openSuse with “the one that we don’t speek of”. :wink:

I would like to use the Aptana Studio2 and/or RadRails2 plugins for Eclipse but they require Eclipse 3.5 or better. Since Eclipse 3.6 is the current version why isn’t the repo at least up to v3.5?

Transmission is also outdated. v1.93? Come on it’s up to v2.12.

Eclipse is a Java program and you can just extract the latest version (download it from into any directory and then create a soft link to run the program. For example, if you have extracted the files to eclipse directory under your home directory:

ln -s $HOME/eclipse/eclipse $HOME/bin/eclipse

I don’t know what the OP’s problem was, but I did install Eclipse 3.6 to my home directory, created a Menu Item (that was an adventure), installed the Aptana Studio2 plugin, and it starts up and runs fine. Also ran fine from the command line.

Now I have to decide which Ruby to install, the repo version or the current version. I think jRuby is installed but it is not recommended for use by the app.

I’m not familiar with Ruby development under Eclipse. Anyway, whatever you install from within Eclipse should work fine.

I installed the repo version, Eclipse picked it right up, and installed all the gems without a problem.

Now where did I put that Ruby on Rails book I had? I’m sure I’ll find it. :slight_smile: