inserting usb stick starts hundreds of konqueror instances

I am running opensuse 13.2 with kde 5, and this problem has persisted through several updates, I believe. When I insert any usb stick into the laptop, a small window emerges suggesting “Open with File Manager”, which seems logical. If I click on this option, the system starts to open hundreds of konqueror instances and goes into 100% load.

I have only found one way to stop this once it begins: pull the power plug and do a hard reset.

I have only found one way to avoid this to happen in the first place: totally disable konqueror (by renaming its executable)

None of those solutions are of course satisfactory in any way. Can anyone tell me why this happens and what I can do to resolve this?

Thanks.

I tried that with Tumbleweed (I don’t have plasma 5 installed on 13.2).

When I plug in the USB, the device notifier shows up in the tray. That has an entry for “open with file manager”. When I click that, Dolphin opens.

There’s probably something in your settings to make konqueror your preferred file manager. Maybe you have settings that originated long ago in an earlier KDE release, and those are causing problems.

You should be able to crash the Xorg server with CTRL-ALT-BACKSPACE (repeat twice). That’s better than powering off.

This is highly probable - would anyone know where I would change this?

…also helpful, must try to remember that, but will of course prefer that the situation never arises…

Start by creating a new user account. And test with that. The new user gets fresh settings defaults. That should help distinguish between problems with system settings and problems with user settings.

systemsettings5->Applications->Default Applications.