Inputs not used through USB hub

Hello,

I have a USB hub on my desk, 10 ports with external power supply, that I use for ease of access, powering random stuff, and for easy switching of keyboard and mouse to my Raspberry Pies. After dist-upgrading and rebooting this Sunday morning (2020-02-16T09:21Z), my keyboard and mouse did not work (I zypper dup every Sunday morning).

They work fine when plugged in the front USB ports of the PC. Keyboard works fine through the hub in BIOS and GRUB. USB sticks work fine through the hub. Hub works fine with another PC.

Outputs of lsusb and dmesg are strictly identical when connecting and disconnecting to the hub and front ports, modulus the actual USB tree structure and device numbers: they are correctly detected and drivers properly loaded.
Xorg log shows connection/disconnection when done through the front ports, but absolutely nothing when done through the hub.

I tried force-reinstalling libinput, but the problem persists.

Any idea? What could be interfering between the kernel and Xorg?

Thanks,


cigix

sorry I cant help but monitoring this thread … I have more then one distro on my main rig here and I am seeing the same thing … I didn’t have time to look at the logs (and to be fair i forgot which one to look at) but I cant get my mouse to be seen by OpenSuse TW (latest update) … even rolling back to any of the other installed kernels (some of which i had been on and there were no problems) worked fine.

Right now my mouse is plugged into a usb hub and all other distros are fine (so that means it’s not a hub failing or usb mouse failing), not trying to start “a distro war” with that comment, just to be clear.

Plugged into a usb port directly on my laptop, the mouse works fine, in TW. I did not check if usb drives are seen via the hub, on TW but I may check that later.

update: in MY case dmesg and lsusb list the exact devices plugged into the hub but they do not seem to function … so “TW does see” the devices … I would have just added this to my prior post but i didn’t see an “edit post” option

A bug report might be appropriate here.

Submitted my issue at 1164616 – Devices plugged into USB hub, that previously worked, stopped working the past few days

Thanks for reporting back the bug number.

Same issue here, KDE Plasma5.18.1, changing to console using ctrl+alt+F2 e.g. makes keyboard work again.

I have been updating (dup) and rebooting … issue still isn’t fixed but today I made a stupid realization … I forgot to test a fresh user account … well it didn’t make any differences anyway … I should have checked that before though

A fresh install doesn’t change nothing for me either;
could this issue be linked to this forum entry and this bug entry for arch linux?
At least that might be it in my case, I have an Amazon basic 7-port hub (Terminus Technology Inc. FE 2.1 7-port Hub) and the arch user has the same one.
So it’s very likely both issues have the same cause.
In that case, it would be a systemd bug and we’d have to wait until it’s updated.

BUT I just noticed that the bug shall just appear with systemd version 244.2-1 and be fixed with 244.2-2. At least at Arch.
The problem is that I’m currently running 244.3-1, which is a version ahead and should also contain that fix, right?
In that case, the question is, why it’s not fixed on Opensuse.

I hope I could help and provide some useful information!

Cheers!

Create a bug report on bugzilla.opensuse.org, you can use the credentials you use here.

going off a link in one of the links provided I found a post/issue on github https://github.com/systemd/systemd/issues/14822
By the way … on Tumbleweed like I said and here is what I have for the systemd version (I have been doing my usual “zypper dup” and testing from time to time to see if it’s fixed


Version        : 244-3.1  

Hey,

good news, I found a solution to make keyboard and mouse working again using a USB-Hub.
It is, indeed, a systemd issue and I solved it by installing systemd 245 from this repo.
Or the direct download link for systemd.

Afterwards, I could plug in my keyboard and mouse to the hub and they were fully functional!
Could someone confirm that please?
But it’s still some kind of risk to install it on a daily driver since it’s not an official release and may (probably) contain bugs!
I just tested it on a USB-installation for a short period of time.
So be aware. On the other hand, it’s OpenSUSE and these packages shouldn’t create too much trouble, I still can’t guarantee it.

I hope it helps you!