Input devices freeze at login


I have this on/off problem (probably 20% of boot attempts).

This only happened after installing OSuse 11 (clean install, keeping home folder).

When the boot process is starting I see the following messages (copied form /var/log/boot.msg)

By the way, due to my motherboard, I must use the “irqpoll” option to boot and have access to CD-ROM and IDE HDD.

<6>ata1: PATA max UDMA/100 cmd 0xdc00 ctl 0xd880 bmdma 0xd400 irq 16
<6>ata2: PATA max UDMA/100 cmd 0xd800 ctl 0xd480 bmdma 0xd408 irq 16
<6>ata1.00: ATA-6: ST3120022A, 3.01, max UDMA/100
<6>ata1.00: 234441648 sectors, multi 0: LBA48 
<6>ata1.01: ATAPI: HL-DT-ST DVDRAM GSA-4082B, A201, max UDMA/33
<6>ata1.00: configured for UDMA/100
**<6>input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input2**
<6>ata1.01: configured for UDMA/33
<5>scsi 0:0:0:0: Direct-Access     ATA      ST3120022A       3.01 PQ: 0 ANSI: 5
<5>scsi 0:0:1:0: CD-ROM            HL-DT-ST DVDRAM GSA-4082B A201 PQ: 0 ANSI: 5
<7>ahci 0000:02:00.0: version 3.0
<6>ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 19 (level, low) -> IRQ 19

What happens is that sometimes the boot will sort of pause for 2/3 minutes in the Input/mouse message.
And then when the login screen appears, my mouse and keyboard don’t work. I have to press the shutdown button on the PC and it turns off. I use a wireless mouse and keyboard with a common receiver.

I previously wasn’t able to use the wheel mouse, but I looked for that and removed the “Option “AutoSoft” “on”” from the mouse configuration in xorg.conf (is it supposed to have 2 of those files?).

Well… If you can think in anything, I would appreciate!!

Bad news. All my experience tells me cordless mouse and keyboard are the source of much pain and sorrow, regardless of operating system. After several years of customer service work with elderly computer users, I always recommend they replace them with the wired stuff.

I have Logitech wireless mouse/keyboard combinations for my SLED and
one of the openSUSE 11 systems and have never had any issues…

To the OP, have you tried the insmod=ide-generic option at the grub
screen rather than disabling irqpoll? Or is there an option in the BIOS
to set PATA devices rather than PATA/SATA or SATA?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 11:27, 1 user, load average: 0.02, 0.08, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

This probably is of zero value, but fwiw . . . I have a wireless mouse connected to the USB port. I need to have “legacy” set in the bios for it to work.

Use USB wireless mouse and keyboard
Never set any thing , works with all my distros ,
no problem at all

Well, Thanks for your help!

br073n: lol!.. I respect your position, but my experience does not confirm your idea… My mouse works perfectly when the computer starts well (to be honest, most of the times) and never had any problem in OSuse 10.3 or Windows. So… it’s probably not the mouse! But I?ll admit it’s my first cordless device!

malcolmlewis: I think I’m a little lost… I’ll try the ide_generic option (although I remember trying it without success in 10.3). My bios has an option to configure SATA as IDE or AHCI. I’ll will check how it is set and report back (I can’t really remember, but I sort of remember it being the only way it worked…).

dobby9: Good for you! lol… just kidding. My works fine most of the times, too…

mingus725: I’ll check that to! Thanks.

I have exactly the same problem, but I work with a laptop. Under Ubuntu 8.04 my keyboard and touchpad work great. Checking dmesg tells me, that the keyboard isn’t detected and the touchpad is detected as a PS/2 Mouse.
After a reboot everything’s fine.


So my problem persists! Every 2 or 3 times the computer will freeze at that point. Is almost as it needs to warm up. Usually, at a second try it will go smoothly.

I checked my BIOS. It’s configured to SATA as Compatible, IDE.
And JMB363 Mode Select AHCI.

The IDE_GENERIC without the IRQPOLL didn’t work. I don’t know how to reproduce the error, but it’s related to my mainboard, and the fact it has a Jmicron chip. I resolved it with the IRQPOLL switch at the time.

So. Any more suggestions?



In my case, the mouse and Keyboard ‘freeze’ a few seconds after complete logon. A symptom kind of like the old IRQ conflict.

I my case this seems to happen when I set the screen resolution to the native 1680 x 1050. when I put it back to 1280 x 786 it works fine. Sure would like to use a higher resolution, but so far, can not.

This is just a wild stab at it, so a big fwiw caveat . . .

Googling around it’s clear that there have been a lot of different hardware problems with linux and JMicron boards. Some have apparently been resolved by the user building his own kernel; maybe worth a look, esp on the Gentoo forums (them’s hardware jocks over there).

I would try running off the 11.1 Beta CD for a while, with its 2.6.27 kernel . . .


Thanks for all your help.
After a (long) time, I finally found the problem (I had created myself).

I installed OpenSUSE with the HDD bios configuration to AHCI. And later changed it to Compatible - IDE (since Windows wouldn’t start…).

So, there you go!
Thanks again!!