Inkscape - guidelines don't work

In Inkscape,when I click and drag from the ruler, I expect to see blue guidelines appear which I can then position, and later reposition by clicking on them, and get more detailed control through a dialog that opens when I double-click on them. What actually happens is that red guidelines appear briefly, and then the whole window moves. The red guidelines remain, adjacent to the ruler, but I can’t click or double-click on them. It gets weirder.

I have 2 laptops and a bootable USB that exhibit the same behavior. They’re set up in similar fashion with KDE, but use different appearance settings (color, plasma theme, icons/cursors). A bit of googling suggested that this problem can be the result of the selected gtk theme under kde, but I tried changing these to no avail. I also installed xfce (which is based on gtk like inkscape) and icewm, same behavior there.

If I go into system settings and return the theme to opensuse default, no change. However, I can create a new user account, and the problem doesn’t happen, even in kde. If I go back to my main user account and run inkscape as that other user (or run as root), it works correctly a couple of times and then the erroneous behavior starts on the third time I start inkscape.

Figuring I had messed up some setting, I deleted ~/.config/inkscape, but it made no difference.

So, I can create another user account, set up everything the way I like it, delete my original account and probably be happy, but I’m afraid that since I don’t know what caused it (on all 3 installs), it could come up again. So any ideas as to the root cause? Has anyone seen this before with plasma 5.17?

I’m not sure when the problem first occurred, because I only just started working my way through inkscape tutorials.


PS: Same results with inkscape appimage.

It works here.
If it is a theming problem with gtk, since you use it first in kde, try deleting the gtk2 and gtk3 folder and config
in your /home/blah if you have and do it also in /home/blah/.config. Logout and login after doing so.
I use xfce 4.14 in leap 15.1 and tumbleweed.

Thanks, conram, that worked, specifically ~/.gtkrc-2.0

The specific problem in kde systems settings was choosing the gtk2 theme oxygen-gtk (from package oxygen-gtk-engine). The good thing about it is that it uses system colors for gtk apps, but evidently it screws up inkscape’s guideline feature and also fails to remove itself when I select a different gtk theme.

Hi, good to see it worked.
I try to avoid configuring or touching the gtk theming when using kde in system-settings.
It sometimes screws some of the gtk applications.