Ink Level Monitor

Hi! Is there an ink level monitor for openSUSE 11.0 (KDE 3.5) that will work with an Epson Stylus C44? I tried the one in the Control Centre under Peripherals->Printers but it didn’t seem to work, just came up with an error message that said “Cannot open /Stylus C44 read/write: no such file or directory”:confused:

Thanks in advance!

This may help: :: Choosing an ink-level monitor

Good luck:)

Thanks for the link! A lot of really good info on there.

I installed libinklevel and ink from the repos so now I can check ink levels from the command line by typing:

ink -p usb

At first I had to su to root to get it to work. Then I discovered I needed to add my user account to the lp group in the YaST Control Centre under User Group and Management then after a reboot the command works for a normal user!

Didn’t have so much luck with the GUI front end though: I installed SuperKaramba from the repos and downloaded the Cynapses and Ink Level Monitor themes from Cynapses worked fine but when I tried to load Ink Level Monitor an error message stated “one or more of the required components of the Kross scripting architecture is not installed”. Eventually figured out I needed to install python-kde4 then after another reboot the theme loaded without complaining. Unfortunately the widget is completely blank. Doh!

Is there anyone out there who’s had any better luck with this than me?

I’ve noticed that every time the desktop loads Karamba tells me Desktop Effects are turned off. When I try to turn them on, the enable effects tick-box just un-ticks itself whenever I click the “tick” button next to the drop-down menu. Could this be the reason for the blank Ink Level widget? I must have lost desktop effects after updating compiz-fusion earlier today so hopefully another update will fix both problems!

I searched for the Inkblot program in Yast on my suse 10.3 and my 11.0 machines. On my 10.3 machine, I can find it and install it via Yast. On the 11.0 machine, I searched for it in Yast but couldn’t find it.

Great work, harlequin501

I am monitoring this thread closely.

Thanks for effort


Still no luck with the Karamba ink monitor but I got Inkblot installed and it works a treat! It isn’t in the 11.0 repos like BNG22908 said so I had to download it from the Packman site at PackMan :: home then right-click the rpm file and select “install with YaST” then reboot. Not used to all this rebooting in Linux but at least I’ve got a working ink level monitor now!

Thank you to Heeter for your supportive comment and to BNG22908 for suggesting Inkblot!

You don’t need to reboot after installing Inkblot, just turn printer off and on again and it will work. My mistake!

Now that’s what I’m talking about, the power of the Linux community. Thanks for that info Harlequin501! Now I can run Suse 11.0 full time.

Thanks again, Harlequin.

I am having install issues with dependencies with inkblot. Too many to list. Wish there some way to install through packages instead.

Will try again, later.

Great effort, H.


Uh-oh, is anyone else getting this error when they try to start inkblot?

user@MyMachine:~> inkblot
inkblot: error while loading shared libraries: cannot open shared object file: No such file or directory

It’s probably not installed. See:
RPM Search

(packman has it for 11.0)

I installed that RPM. Now it’s saying

Inkblot Error

No supported printers found.

Please check your printer and cables and restart Inkblot.

I already tried restarting my printer. Does anyone have any ideas?

Mmm, maybe this sets you on rack:
GnomeFiles - GNOME/GTK+ Software Repository

Did you add your user account to the lp group (YaST Control Centre -> User and Group Management) then reboot? If you did that already then I’m out of ideas:(

I am using ink from packman not inkblot. Check it out
Type ink
or ink --help for options when you are able to install it

BNG22908, for no apparent reason Inkblot gave me exactly the same error message you had:

Inkblot Error

No supported printers found.

Please check your printer and cables and restart Inkblot.

I tried using Ink in the terminal but it gave me a similar message. Then I tried printing something off in Open Office and nothing happened. Oh-oh. I quit Inkblot and tried to print again. Thankfully I could print again. Loaded Inkblot back up again and – it worked, as did Ink. Bizarre. Some weird bug in the system somewhere! Don’t know if this will help you get Inkblot working on your box but hope so.

Did you check if your printer is on line

Here is my output

con@linux:~> ink -p parport
ink v0.4.1 � 2007 Markus Heinz

Canon iP4000

Photoblack:                   100%
Black:                        100%
Cyan:                         100%
Magenta:                      100%
Yellow:                       100%

The printer is used as a network printer attached via usb to a router print server and connected also to a pc using parallel port

Printer is connected directly to PC via USB and it was switched on and properly connected the whole time. I suspect gremlins.