Initializing gfx code

Running a Lenovo ThinkPad T440s laptop with an external USB Wind Drive U0882 DVD.

Tried to upgrade from 13.1 to Tumbleweed via command line using documented method.
Things were not quite right after reboot (it happens, no big deal), so I downloaded Tumbleweed x86_64 ISO image.

It froze at “Initializing gfx code.”

I thought maybe a missing driver might be the issue, so I downloaded and tried openSuSE 13.2 and 13.2 Live KDE.
Same problem.

I’m very willing to hear suggestions for proceeding. Right now my only path seems to be reversion to 13.1.

Solved. Documenting what worked for me, for anyone who has the same problem.

Before I created the thread, I had done the research and it was clear the problem spanned years and distributions, and was sometimes reported as happening erratically. I was thinking initially it was looking like a driver issue, and then some kind of deep-guru hardware initialization/interrupt thing.

I verified this repeatedly:

From a power-down state, the boot freezes with “Initializing gfx code.”

However, if I have a running Linux instance, plug in the external USB hard drive, wait for it to be recognized, and then go to the root prompt and issue the “reboot” command, it works.