init 3 command

The command resulted to prohibit all remote connections. Without this I can not install nvidia driver.

In Grub2 type “e” and go to the bootline:

linux /boot/vmlinuz-4.4.1-2.gddc5d70-default root=UUID=9944c34a-70d5-4ba1-bae8-99566d31287e resume=/dev/disk/by-uuid/b9b93af6-b136-487f-b646-8587fd0676e7 splash=silent quiet showopts nomodeset elevator=deadline

Type at the End a Space followed by 3 and boot with F10.

from the command line, try


to establish network connections if not available


If you use NetworkMaager then it must be set to allow all users or it does not start until a user logs

Nope, you can. The NVIDIA blob also provides documentation, which contains options one can use to install the driver:

  • –no-x-check
  • –no-nouveau-check
  • and last but not least: --dkms (dkms needs to be installed)

The best way to have TW start in the old runlevel 3 ( btw “init 3” should work, systemd knows how to deal with the command ) is to hit “e” in GRUB, then use the cursor keys to get to the line that has “showopts” at the end and add " 3" ( NB. space 3), then hit F10 to boot.

Sauerland]( I am OUT the machine, remote. Using grub, legacy.

gogalthorp: I am not using NetworkManager.

keellambert: I have to restart the machine by the ISP after EVERY attempt.

Knurpht: (–no-x-check)
“ERROR: An NVIDIA kernel module ‘nvidia-modeset’ appears to already be loaded in your kernel. This may be because it is in use (for example, by an X
server, a CUDA program, or the NVIDIA Persistence Daemon), but this may also happen if your kernel was configured without support for module

It worked before newest kernel module/system update. The main problem is the init 3 command. I am the root. Who locks out me from my machine?

Login as root, type:

init 3

Than you should be in init 3.

Or the systemd command?

For runlevel 3
systemctl isolate

For back to runlevel 5
systemctl isolate

Set default to runlevel 3
systemctl set-default

Set default to runlevel 5
systemctl set-default

I just tried “init 3” in up-to-date TW and it indeed is “stuck” on empty black screen. Ctrl-Alt-F1 returns back to tty1. So the problem is that “init 3” does not switch to tty with text mode login.

Sauerland, Malcolm: I think you do not fully understand the problem: I can not reach the machine remotely after init 3 at all; lockdown. The only one solution is restarting the machine by the ISP. And I do not want to fix the operating system after login and make more experiments…

And I think it is not one/only my problem: it is (maybe) originated from the new system approach of the developers… just one not correctly thinking and programming policykit or system-building restriction can result such very risky behavior… overrules root privileges and hacking the whole Linux security structure… I only hope I am not right…

Then you should be using wicked for network access, esp if remoting in, or configure NetworkManager and select the ‘for all users’ setting…

I do not understand. The remote machine uses wicked, I think. And the problem is that the machine closes all connections and disables all login attempts AFTER init 3 command…
How can I prevent it BEFORE init 3 and then execute the command seamlessly? It is not my special problem, I think…

Ok well it should not do that it is not normal. Be sure that

is set for run level 3 in systemd

Maybe it is set to single user or something else

To the OP:
Have you considered booting to Emergency/Recovery mode (Grub selection)?

The result should be a graphical environment with working network connections, but without the Desktop graphical driver (you’d be running the VESA driver loaded by grub). Should address your issue, if the idea is that the new driver cannot be installed because the legacy version of the driver is being used.

Within that graphical environment, you can open a windowed console instead of invoking INIT 3 if you wish to use a command line.


It depends what problem you have. What I can reproduce is

  1. switching between “run levels” does terminate exiting ssh connections. I think it was discussed upstream and I was sure it was also fixed, but may be sshd service needs some adjustment. This would be valid bug report.
  2. By default SuSEfirewall2 service is active. If I stop it, I can login; but when changing run level service is started again so I am “locked out of SSH access”. It is unlikely to be your problem, otherwise you would not have access to the system from the very beginning. If I disable SuSEfirewall2, there is no problem switching run levels (modulo 1).

In this particular case I’m using NetworkManager with system connection and this connection remains present across run-level change.

So I’m afraid this is your special problem and you need to debug it to understand what happens. Start with enabling persistent journal and examining logs after run level change. It makes sense to increase systemd log level to debug to see what it does before switching run level (/bin/kill -RTMIN+22 1).

P.S. and in any case, having remote server without console access is e-h-h … unwise. You will need console access sooner or later as you have seen …

gogalthorp: I can do anything AFTER I can login… but I can not do, only after the clean restart.

tsu2: the machine has automatic restart.


  1. Right. I can not login nor via vnc and neither via ssh also. It is not an ssh problem, it is a root session (not root login) problem, I think. Nobody(‘s program) should punish the roots’ activity.
  2. I wont stop firewall on the WAN except from emergency case. It is not that. If it is a firewall conflict (or maybe not), somebody setup this nowadays. Same command could be ordered before last update.

Special problem: I consider that replacing and integrating the direct root commands (init, start, reboot, shutdown and so on) into the system workflows is a very risky decision, it is my personal opinion. No asking, no warning, but sudden crash… Somebody does it, somebody should fix it, if an error occurs. I am not a guru, i do not want to make changes in the system architecture.

Console: Yes, I can ask the ISP to establish a secure console connection, but it is not permanent. I made it a few times. It is free now, as I know, but a bit complicated to build up. And I think a server should run for months without stopping, they wont be happy about these serial problems…

“Right” what? I have no problem to login after “init 3”.

Via vnc or via ssh?

Via ssh. You did not mention VNC at all before my post, you said “access remotely” which includes ssh :slight_smile:

Hmmm… I repeated it… no success, lockdown, ISP restart.

I looked into the journal, no red record in the lockdown (there are some after restart), the relevant firewall record:

Feb 11 10:22:20 paradigm kernel: SFW2-INext-ACC-TCP IN=enp2s0 OUT= serverMAC SRC=myIP DST=serverIP LEN=52 TOS=0x00 PREC=0x00 TTL=57 ID=7344 DF PRO
Feb 11 10:22:20 paradigm sshd[4760]: pam_unix(sshd:session): session closed for user “meuser”

Maybe “enp2s0” is weird (there was one half config change in the hardware, from Intel to AMD)?
Network usage: