index.html page

how can i put code into “/srv/www/htdocs” and access it without an “index.html” page. in windows i just dump all code into the htdocs folder for apache and when accessing “http://loclahost” it all comes up for access. in suse i get error msg saying to the effect that i need an index page, but i do not know how to build one. is there a workaround for this??? running suse 11.1

many thanks for any help!!!

That’s most likely because that directory doesn’t allow indexes, just add Indexes to the Options part of your web root in the httpd.conf file and you’ll be able to see all the contents.

It is a problem with permissions
In a console type su then root pass then chown -R yourusername /srv/
may also need to give it write permission change it with chmod 775 /srv/www/htdocs

index.html is just the start (first page) in you web dir

a simple one could look like this:

<html>
<header>
<title>My start page</title>
</header>

<body>
<h1>Heading for my start page </h1>
<p> text in my start page</p>
</body>
</html>

Geoff