Incredibly slow internet

Hi all,

for a few months now, my system has developed a seriously slow internet connection issue. As in download speeds in the <100KiB/s rate (and lower). At first it was sporadic, but now it’s constant. I have not changed anything, other than the usual updates. The site I go to does not matter. The system is dual boot and Windows is fine, so it’s not a hardware issue. I swapped my network card when this first happened, thinking it was the issue. It’s not.

I’ve searched and found others have had a similar problems over the years, but I really do not know where to start to troubleshoot the problem. My system is directly plugged into the router, ie. the connection is via LAN cable, not wifi. It takes about 20 min to do a software update refresh…

Details below. Thanks in advance.

Operating System: openSUSE Leap 15.4
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.14.21-150400.24.33-default (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-4460 CPU @ 3.20GHz
Memory: 31.2 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

During the past weeks I experienced some network problems related to DNS. When setting up a new configuration DNS worked fine in the beginning, but prolonged operation resulted in puzzling issues.

You may reboot your router and see if that helps. If it doesn’t look for clearing the DNS cache.

Interesting, things seem better after a DNS clear (using ‘rcnscd restart’ as root). I’m not 100% sure as yet, but I’ll monitor. Thanks for the advice.

If anyone has any other suggestions, I’m more than grateful…

Presumably you reset the cache of the client. You need to reset the cache of the local DNS server on your router. Rebooting the router won’t help in many cases. The exact procedure depends on the model. With my FRITZ!Box 7530 AX I searched fritzbox 7530 clear dns cache - Google Suche

I think that if the ADSL/Fiber modem was the problem both Leap and Windows would see the problem.

I would switch to some speedtest site, try when things are fine or on Windows and also try when things are slow. How much difference is there?

Unlikely, but check “ip -s link”, any error counter non-zero?

Did you try another browser?

Yep, that’s what I did, the client. I cannot find a way to reset the DNS cache on the router. Google is no help. The general wisdoms seems to be rebooting, but, as you said, it does not always work.

The speedtest for both Win and Linux is the same, when I’m able to get to the test site in Linux. Quite often, I’ll attempt to run the test and it says “connecting” for several minutes and I hit cancel. I have tried Chromium and FF in Linux.

On occasion, Network manager tells me “your system seems to be on a network, but is unable to connect to the internet” or something very close to that.

Reseting PC DNS cache seems to have made a difference, but I’m still having significant issues with extremely slow speeds.

Anything connected to the router via wifi runs fine, the issue is specific to my PC running OpenSUSE. Again, this system is fine when booted into Windows. The PC is connected by LAN cable to the router. I’ve swapped the cable, but again, it’s fine with Windows.

ip -s link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
RX: bytes packets errors dropped missed mcast
24140 300 0 0 0 0
TX: bytes packets errors dropped carrier collsns
24140 300 0 0 0 0
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
link/ether 08:be:ac:20:5f:72 brd ff:ff:ff:ff:ff:ff
RX: bytes packets errors dropped missed mcast
182686515 171765 0 0 0 1573
TX: bytes packets errors dropped carrier collsns
106735318 140401 0 0 0 0
altname enp1s0

What’s the network card, and which driver are you using?

If it’s a wired connection, are you manually configuring the network speed, or using the auto-detect settings to set speed and duplex?

Several years ago, a friend of mine pointed out that depending on auto-negotiation for network card speed/duplex can cause issues. I personally never experienced that, but the protocols used for that can act wonky in some circumstances.

If it’s wifi, it may be something else - transmit power (how far are you from the router?) for example.

ETA: I see now that it’s a wired connection.

If speedtest is coming back fine once you get connected, then it’s likely name resolution instead, as others have suggested.

If you have experience with Wireshark, you might start that up as root and see if it turns up anything. I suggest that because it sounds like you might have the tech background to work with packet traces. :slight_smile:

Okay, it was not immediately clear to me but indeed if the problem is already with connecting to speedtest then things like DNS would be likely.

Your interface counters so no error counters being non-zero, so no low-level Ethernet problem.

Two more things you can try when you see this slow behavior:

  1. Run on the command like "dig " with the address of the site being something you did try (“”) but also something you did not try before. Typically this should return immediately.
  2. Check the basic connectivity/raw dowload speed

On 2), I found Test File Download and had a look at the 20MB file.

You can download that using:

 > wget
--2022-12-18 09:09:33--
Connecting to connected.
HTTP request sent, awaiting response... 200 OK
Length: 20971520 (20M) [application/zip]
Saving to: ‘’     100%[====================>]  20.00M  6.60MB/s    in 3.0s    

2022-12-18 09:09:36 (6.60 MB/s) - ‘’ saved [20971520/20971520]

By using the hardcoded address you rule out DNS. If that triggers any problem or slowness, paste the complete output in this topic.

Flushing the DNS cache depends on the router model. What is your make and model?

It’s a Netcomm NF18 Cloudmesh. I’ve looked at the manual and it’s not helpful. I’d appreciate any advice.

Will do, I’ll probably not get a chance to get back to this until next weekend.

I’m using autodetect settings, I’m not sure about the duplex, I’ll check. The issue happens with the network integrated into the motherboard and the new one I bought when I thought that was the problem.

I’ve played around with Wireshark, I’ll take another look and see if I can make sense of the output.

I usually only have time to play around with this stuff on weekends, so I’ll be slow in reporting back.

This is a quite standard device. Try to remove the client from its network menu. This will flush the cache. Does the NF18 add it again automatically?

Yes and yes. I feel I’m slowly (no pun intended) getting somewhere…

When I use ‘dig’ the return is immediate even with new sites. The 20MB file takes 5.7s for me (I’m on a 50 mbps download plan).

I’ve noticed other apps (running on my phone, ie. not related to the PC), can be a tad slow to respond as well on occasions. It’s making me lean more towards the router/modem being the issue. Why Linux seems to be more affected is unclear.

I’ve just rebooted the NBN box and router (again) and things seem more responsive.

Link negotiation is set to ‘ignore’. I can pick auto or manual. I have a play with Wireshark as well.

Should be set to auto.
Have a read:

1 Like

That looks good.

I assume that is when you hit the “As in download speeds in the <100KiB/s rate (and lower)”.

How do you observe this slow download speed, is it via the browser and if so which browser?