incredibly slow internet connection

Just an information if anybody else has this problem:

After installing openSuSE 11.0 I noticed that my internet speed is somewhere near 1kB/s, connected to a 2Mbit DSL router. After searching a bit regarding my network card (Realtek RTL-8139), I noticed that I have to set a system control parameter to get full speed back. The setting I had to apply was:

net.ipv4.tcp_window_scaling -> set to 0

After setting this speed was back at 200kB/s

Checking your current setting can be done as root using this command:

cat /proc/sys/net/ipv4/tcp_window_scaling

Setting it temporarily for testing by using this command:

echo “0” >/proc/sys/net/ipv4/tcp_window_scaling

and setting it forever can be done by adding the following line to /etc/sysctl.conf

net.ipv4.tcp_window_scaling = 0

and running “sysctl -p” once.

I hope this helps other having similar problems.


I have a similar problem.

I recently installed Ubuntu 8.04 on a old work computer that was lying around and noticed the internet was incredibly slow so as to be non-existent. I’m using a Linksys WUSBG54 (or something like that) usb dongle to access wireless networks, seeing as the machine doesn’t have a built-in wireless card. It worked fine with Windows, so when I tried Ubuntu I assumed it was just poor support in Ubuntu itself, so I switched to opensuse 11. I was having the same problem, so I did just about everything I could think of and none of the solutions I’ve found have worked. I’ve tried what you suggested, but it wouldn’t let me make changes to the sysctl.conf file at first, so I logged in as root and made the changes and ran sysctl -p, and nothing changed. I’ve disabled ipv6 in both YaST and Firefox, and still nothing. opensuse can still detect and connect to wireless networks via the usb thing, but web pages load (if they do at all) at about one small page (i.e. google) an hour.
Using a wired connection is out of the question, since our router is in the basement and I can’t really have the computer down there.

Oh, and I’m using GNOME not KDE4.

Any help would be extremely appreciated!

You may want to have a look at this article located at SUSE & openSUSE tutorials,howtos,tips,tricks, troublehooting and Search for Network Performance Fine Tuning.


@esferous: Just to get some basic information…

Looking at the output of ifconfig and iwconfig :
does ifconfig report errors or drops on your wlan0 ?
what does iwconfig say about signal strength and link quality?

Another problem could be DNS resolving… using nslookup and entering different server names at the prompt (e.g., ,etc) - do the names get resolved correctly? Try the same thing using the ping command.


It appears that not only do I have wireless networking problems but some serious terminal issues as well.

Both of the commands I tried(iwconfig and ifconfig) were not recognized (bash: command not found) but when I typed “info ‘example’” it gave me the detailed descriptions of the commands. If a command does work, then it usually responds in a strange manner. Sometimes asking for a root password and then does nothing, sometimes giving me a new line underneath the regular prompt (my name@linux-uoq7) and turning out weird characters when I hit the arrow keys or something similar.

I would give you the information that you asked for but I can’t get it myself! I remember some info I got when I was working on the problem in Ubuntu, though.

The link quality is always around 30 or 50 percent, but never greater. The bit rate would be 54M consistently, except for a few times when it would show just 1M. I could change it to 54M with ‘iwconfig wlan0 rate 54M’ or something, but the speed never changed.

I tried nslookup like you said Magic31, but it just made a new line like I said earlier.

I know that the Internet itself is just fine in my house; we have like 6 other computers all connected to the wifi and working fine.

I also tried some of the things suggested in the article mentioned by etech97 and they wouldn’t work because of the terminal acting up.

After all these weird errors with the terminal and to a lesser extent the wireless, I’m wondering if openSUSE is really the linux for me. I do like it a bit more than Ubuntu, but these weird mess-ups are putting me off. I was mainly planning on using the computer for things like movies, some basic internet stuff and some games.

I’m sorry if I post ridiculously long messages and sound like I’m ranting, but I’ve just been going insane trying to get this to work! Thanks for your help so far, though.

you need to run these commands as su

Hi esferous,

Sorry for that… You don’t have a terminal console issue, but the commands should be run as root. So open a terminal console, type:
su -

and enter the root password. After this the commands should work.

Nslookup is a tool that connects to your default DNS server.
When you type in a name and hit enter, nslookup will query the DNS server directly… if all is well you should get a reply with the server name and corresponding ip address.

If nslookup works as expected you can exit it and try the same with the ping command. (e.g. ping )
Ping will try to resolve the name by using local programs… if this also works (the reply is not that important, more important in this case is that the name is resolved to an address) you are then sure that is okay too…

If you’re signal quality is too low, you will also get connection issues but that is probably not whats causing you the internet pain.

Have another go using the commands as root & let us know what you find.


That would be because those commands are normally run by root user
who’s path to the commands isn’t in yours. Either use the su - command
or use the full path which is either /usr/sbin or /sbin :slight_smile:

Now, that said, some commands work, some don’t, some when run may only
give limited information.

bash: iwconfig: command not found

lo        no wireless extensions.

eth0      no wireless extensions.

bash: ifconfig: command not found

bash: /usr/sbin/ifconfig: No such file or directory

eth0      Link encap:Ethernet  HWaddr 00:0E:7B:CE:99:70
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2 days 22:06, 2 users, load average: 0.04, 0.05, 0.07
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Ah crap.

I was just about to post my reply with some info, but there were problems with the site and I lost my post.

Long story short, I didn’t think of logging in as root, and when I did I could use the commands. Thanks about that. I tried everything again, but still nothing. I think it has to do with the drivers used with the usb dongle.

What do you think? I’ll post detailed info later, I’m tired right now.

Sorry for the double post, but…

I’ve been experimenting and fiddling around with Linux for a while, trying out all kinds of different distros, and obviously so far I haven’t found one that works the way I need it to work. I started out with Ubuntu and then later Kubuntu. Then I tried openSUSE and liked it, except for the annoying internet problems. Tonight I tried a Mandriva Live CD and…the internet worked! Perfectly!

I’m installing it right now! I wish that I could’ve used openSUSE, so if this doesn’t work I’ll switch back.

But thank you all anyway for your generous attitudes! I never got it going (i think mainly because of my own stupidity) but I was surprised by how quickly the community rose to the call of help. Thanks again!

Probably the last time using openSUSE, (i enjoyed my brief encounter with it)

Hey esferous, thanks for the command!

I have a wireless broadband modem and have been having terrible slowdowns at certain times of day, where web pages take three and four minutes to load. Yet if I use YAST to download a program I get 60 Kb/s.

So it does not appear to be an internet connection problem, the slowdowns only occur when I use a browser.

Your command has really seemed to speed things up for me.

I hope this is my solution, but it’s easy to be fooled with these types of things.

Anyone have a clue as to what this command does?