increasing root partition on opensuse 13.2

I created a virtual machine in virtualbox with 20GB disk.

I did auto partitioning and opensuse created 2 partitions. one for root(/)[11GB] and other for /home[9GB].

While updating via ‘zypper up’, I got write error.

I couldn’t do anything after that so I hard reset the machine and it booted to console instead of desktop. I tried to change to different directory and got message that there is no space left.

running df- h tells me that I have used 100% on root partition /dev/sda1(/) and 21% on /dev/sda2(/home). Then I expanded the disk via virtualbox and added another 10GB. Using gparted live disk, I created a primary partition and it showed up as /dev/sda3 in gparted but I can’t see it in opensuse.

How I can move/mount /var to new disk /dev/sda3?

Thanks in advance.

A little confused. default is 3 partitions swap, root, home 20 did for all should be ok if a bit tight. So how big was root?

If this is a new install assuming no or little data would it not be easier to simply reinstall and control how the partitions get divided up. Also with such small partitions it would be best to not use BTRFS and stick with old tried and true ext4 file system. Or be sure to turn off snapper which will eat your disk. Min recommended root with BTRFS is now 40 gig. Crazy but true.

If you want to mount /var on a separate partition you just set the mount point. Of course it will be completely empty so first you would need to copy the /var files to the partition and then rename /var ( best to be running under init1 as root to do it. ) set the new partition to mount at /var then once running remove the old renamed var. the new partition should be in the /etc/fstab but it is easiest to setup using yast


Thanks for the reply.

I did as you suggested by following a tutorial on the same lines as I haven’t played with partitioning and mounting/un-mounting much. I think I did something wrong and system wasn’t able to conenct to netwrok. Also started getting some errors.

So I just deleted the whole VM and built another one from scratch with ext4 and without separate home partition.