Increasing multicast rate for WiFi connection

Hi,

I have two laptops. First one is connected to my ISP via Ethernet connection. At the same time it serves as a wireless router for the second laptop (ad-hoc connection). Multicast routing is managed by igmpproxy. Everything works fine, except that multicast traffic rate on the second computer is very low (1 MBit/s), its too slow for watching television.

After some searching I found that this multicast rate is always minimal one for certain type of WiFi connection (802.11bg in my case) https://lists.ath9k.org/pipermail/ath9k-devel/2010-April/003393.html. For some WiFi kernel modules its possible to set multicast rate by setting appropriate module options. But its not the case with ath9k.

WLAN configuration on the “router” laptop:


iwconfig wlan0 mode ad-hoc
iwconfig wlan0 key 1111111111
iwconfig wlan0 channel auto
iwconfig wlan0 rate 11M
iwconfig wlan0 essid WHATEVER

Do you have ideas how to increase multicast rate on the second computer? :question:

Found some more information:

[ath5k-devel] Configuring multicast/NO_ACK data rate in mac80211](http://www.mail-archive.com/ath5k-devel@lists.ath5k.org/msg02779.html) - here it doesn’t look promising.

Any news regarding multicast rate configuration? - there is a suggestion to disable the lowest rates for both unicast and multicast, however I don’t have an idea how to do this. Any help?

Alternatively maybe its possible to use Madwifi driver (with a patch for ath9k), which has multicast rate control option, but I would prefer to wait with this solution.

On 06/20/2010 03:46 AM, dmko wrote:
>
> Found some more information:
>
> ‘[ath5k-devel] Configuring multicast/NO_ACK data rate in mac80211’
> (http://www.mail-archive.com/ath5k-devel@lists.ath5k.org/msg02779.html)
> - here it doesn’t look promising.
>
> ‘Any news regarding multicast rate configuration?’
> (http://www.spinics.net/lists/linux-wireless/msg49049.html) - there is a
> suggestion to disable the lowest rates for both unicast and multicast,
> however I don’t have an idea how to do this. Any help?

This fix would require patching the kernel. In a quick search, I did not
see where that mask is located, thus I cannot even give you the changes
needed.

I suggest that you place your request for this enhancement on the mailing
list at linux-wireless@vger.kernel.org. There it will be seen by the
authors of mac80211 and its support code.