Increase screen resolution OpenSUSE 13.2 from 1024 X 768

I have an OpenSUSE 13.2 32 bit installed on my laptop.The screen resolution was fine but after rebooting my machine the resolution decreased to 1024 X 768.I am trying to return it to a higher display but fro the displays menu my only option is 1024 X 768 when I run the commands below this is the output

LINUX # /sbin/lspci -nnk | grep VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
Subsystem: Hewlett-Packard Company Device [103c:1484]
Kernel modules: i915

LINUX # cat /etc/X11/xorg.conf.d/50-monitor.conf

Having multiple “Monitor” sections is known to be problematic. Make

sure you don’t have in use another one laying around e.g. in another

xorg.conf.d file or even a generic xorg.conf file. More details can

be found in

#Section “Monitor”

Identifier “Default Monitor”

## If your monitor doesn’t support DDC you may override the

## defaults here

#HorizSync 28-85

#VertRefresh 50-100

## Add your mode lines here, use e.g the cvt tool


disabling kernel mode setting as below also failed

LINUX # sudo /usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg

Please assist.

Anything shown in /var/log/Xorg.0.log?


cat /proc/cmdline

Please use Code-Tags.

I will presume you mean the desktop resolution … and which desktop? likely kde, but you don’t say.

disabling kernel mode setting as below also failed.
you don’t want to disable kms, so I’d revert any such change you made.

Then start by providing a link to the contents of your Xorg.0.log (use susepaste:

I hope this output helps

# cat /var/log/Xorg.0.log
cat: /var/log/Xorg.0.log: No such file or directory

Try ~/.local/share/xorg/ … its evidently the default location now for rootless spun X instances

cat /proc/cmdline BOOT_IMAGE=/boot/vmlinuz-3.16.7-35-pae root=UUID=1f18354c-14c0-47ae-be95-1c8e7add33ec showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe

nomodeset and x11failsafe should not be there … those are the options for the recovery mode boot

Looks like you’re grub entry for a normal boot is missing or messed up

So will I need to restore my grub?If so,please advise on the steps for the best way to achieve this

Perhaps … given from what you posted, I can see that you’re booting into recovery mode … why? I don’t know. but it is suggestive that there may be a grub problem

If so,please advise on the steps for the best way to achieve this
before jumping the gun and running off down that avenue, we should see what your grub currently looks like. Post the contents of your /boot/grub2/grub.cfg file to susepaste (you can “sudo cat …” it)

If its messed up, I’m sure someone will be able to recognize that and advise on how to restore it properly