Incorrect colors, grey and blue after Qt 5.15 update on Tumbleweed

Using XFCE on openSUSE tumbleweed, colors changed after the recent update that included Qt 5.15.
All Qt and KDE programs seem to be affected. It happens with Dolphin, VirtualBox, VLC, KID3, gwenview, strawberry, etc.
Running qt5ct and simply clicking “apply” and the problem is gone I restart the program.

Here is how it looks:

After clicking “apply”, it looks normal again, but it only lasts until I close it and reopen it.

Tried to remove ~/.qt and ~/.config/qt5ct does not help. Same thing with a different user profile.

Dolphin Example:

Clicking “Apply” in qt5ct while the program is running and the colors are normal until I restart the program.

Some highlight colors are dark blue, almost purple.

KDE program crash frequently, but non-KDE Qt programs does not. For example Spectacle right now does not work at all when I tried to do screenshots to attach here.

Application: kglobalaccel5 (kglobalaccel5), signal: Segmentation fault
Using host libthread_db library "/lib64/".
29      return SYSCALL_CANCEL (poll, fds, nfds, timeout);
[Current thread is 1 (Thread 0x7ff69f185c80 (LWP 5597))]

Thread 2 (Thread 0x7ff69d0a7700 (LWP 5598)):
#0  0x00007ff6a0e36fef in __GI___poll (fds=fds@entry=0x7ff69d0a6ca8, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ff69f609862 in poll (__timeout=-1, __nfds=1, __fds=0x7ff69d0a6ca8) at /usr/include/bits/poll2.h:46
#2  0x00007ff69f609862 in _xcb_conn_wait (c=0x5623d2cd7390, vector=0x0, count=0x0, cond=<optimized out>) at xcb_conn.c:480
#3  0x00007ff69f60b26c in _xcb_conn_wait (count=0x0, vector=0x0, cond=0x5623d2cd73d0, c=0x5623d2cd7390) at xcb_conn.c:446
#4  0x00007ff69f60b26c in xcb_wait_for_event (c=c@entry=0x5623d2cd7390) at xcb_in.c:697
#5  0x00007ff69d290f50 in QXcbEventQueue::run() (this=0x5623d2ccfa50) at qxcbeventqueue.cpp:228
#6  0x00007ff6a0fe4871 in QThreadPrivate::start(void*) (arg=0x5623d2ccfa50) at thread/qthread_unix.cpp:342
#7  0x00007ff6a08baeaa in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007ff6a0e41b1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7ff69f185c80 (LWP 5597)):
[KCrash Handler]
#4  0x00007ff6a1625bf0 in QPalette::QPalette(QPalette const&) (this=0x7ffc2d48afd0, p=...) at kernel/qpalette.cpp:655
#5  0x00007ff6a15f69c2 in QGuiApplicationPrivate::basePalette() const (this=<optimized out>) at ../../include/QtGui/5.15.0/QtGui/private/../../../../../src/gui/kernel/qguiapplication_p.h:114
#6  0x00007ff6a15f69c2 in QGuiApplicationPrivate::setPalette(QPalette const&) (palette=...) at kernel/qguiapplication.cpp:3350
#7  0x00007ff6a15fba13 in QGuiApplicationPrivate::updatePalette() () at kernel/qguiapplication.cpp:3322
#8  0x00007ff6a15fba13 in QGuiApplicationPrivate::updatePalette() () at kernel/qguiapplication.cpp:3316
#9  0x00007ff6a15fd778 in QGuiApplicationPrivate::init() (this=0x5623d2cbf680) at kernel/qguiapplication.cpp:1617
#10 0x00007ff6a15fe564 in QGuiApplication::QGuiApplication(int&, char**, int) (this=0x7ffc2d48b200, argc=@0x7ffc2d48b1bc: 1, argv=0x7ffc2d48b388, flags=331520) at kernel/qguiapplication.h:203
#11 0x00005623d1fc525a in  ()
#12 0x00007ff6a0d68cca in __libc_start_main (main=0x5623d1fc51e0, argc=1, argv=0x7ffc2d48b388, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc2d48b378) at ../csu/libc-start.c:308
#13 0x00005623d1fc558a in  ()
[Inferior 1 (process 5597) detached]

Didn’t realize its not possible to insert some small images here, had to remove them to submit the post.

This bug looks to be in qt5ct.
Happens in a new install too when setting QT_QPA_PLATFORMTHEME=‘qt5ct’
Unsetting QT_QPA_PLATFORMTHEME and the colors are normal.

I built qt5ct from the latest code in svn, problems gone. qt5ct in openSUSE needs to be patched: