Incorrect amount of RAM

Okay, so this is probably the first thread I have posted since joining here or at the other forums before this one, so bear with me.

I just completed my install of OpenSUSE 11.0 and everything is running great, mostly at least. There are the usual XINE issues, and nvidia drivers, but I’ll get to that soon.

Anyway, I went through the install, installed practically a full installation, and the system booted. I’m coming from a 10.3 install, so I had the installer format my root partition, and keep my home. No migration issues so far, except for a missing wallpaper, but I will download that later.

Since I kept my home, I still have my karamba applets on my desk and I noticed that my system monitor is showing that I have a whole gig less of memory than I did before the install. This is not good… ha ha.

One other thing that I did notice is that it is running a different kernel than before too. Previously on 10.3 I had the smp kernel, this time the installer went with the pae kernel. I really don’t know the difference, I just want all of my Ram to be available.

Any ideas as to how I can find my missing gig? For the time being we will name it Waldo.

The system is an
AMD Athlon 64 5000+ Dual core at 2.6ghz
An Asus M2N-SLI motherboard
4GB of RAM (Well, Three of you ask the lizard. =)
Nvidia Graphics

can you post the output of free -m

Sure thing.

travis@Jew-Oven:~> free -m
total used free shared buffers cached
Mem: 3295 3176 119 0 308 2158
-/+ buffers/cache: 708 2586
Swap: 4102 0 4102

I was actually tring to remember the command for that, since I thought the Karamba applet might have had something incorrect, but since yakuake isn’t installed anymore I couldn’t simply press the up arrow. :stuck_out_tongue:

hmm seems the kernel indeed isn’t detecting all of your RAM. Can you boot with the below kernel parameter and see if it works?


Alright, I’m downloading the multimedia stuff at the moment, so as soon as that is done, I will try that.

I know very little about the different Kernel types, but that is my gut feeling as to what is causing the issue. This time it does pae, and last time I had the smp kernel. Of course, this guess only comes from the several years I have been using linux and the yast descriptions on the two kernels, but you never know. :stuck_out_tongue:

yeah, SUSE changed the default kernel from smp to pae, no idea why though.

Booted with the boot parameter and the memory count is still the same. Ugh.

For the record, I made sure to take note of the screen when it booted and the BIOS is reporting the right amount of memory.

did you take a 32 bit install ? I didnt know they changed the kernel, but before even with 4GB + the bigsmp kernel could take care of that on a 32 bit system.

Dunno if this is an option in 11 , haven’t played around with it yet. Maybe a bug in the install of a 32 bit system not setting the right kernel flags during install ?

Yeah, I did a 32bit install. I looked in Yast, the smp kernel isn’t even available there. There is the realtime, default, vanilla, and pae. I’m installing the default one now to see what happens.

EDIT: Booted with default, and still the same issue. Still missing one gig of RAM. I guess I will stick with the pae kernel then, since that is what the Suse gods made as default… but still… I want my full four gigs.

Where’s Waldo?

this is strange , because pae should have the physical address extensions, hence the name (pae) … Ill have to get back to you on this.

I appreciate everyones help. Maybe when I reboot back into pae everything will be magically fixed since I had to reinstall it… Yeah… I doubt it.

Anyway, I did come across this and they told the person he needed the bigsmp kernel, which as I said previously, doesn’t appear to be available on the dvd anymore.

With Pae being the standard kernel on 32 bit installs now you wont need bigsmp, pae should be supporting your 4+ GB RAM (PAE = physical address extensions). Something isn’t quite right in your config, or happend during the update. You could always try downloading the sources and recompiling it with the correct flags /options in the kernel config. If it was a major bug I’m sure more would be screaming by now, and the devs would have caught this before the final release.

You know, I love computers. Really. I do. I love how everything they do has a logical reason behind it. You know, like how when you unsinstall one kernel because of an error, install a different one, only to find the error remains, and then go back to the original kernel via a reinstall, and the error magically dissappears.

I swear, the only thing that I did besides visit these forums and a kopete chat session, was dissable all the community repositories because it kept hanging on the nVidia drivers, everything else was the kernel work.

Anyway, the output of free-m:

travis@Jew-Oven:~> free -m
total used free shared buffers cached
Mem: 4051 520 3531 0 21 297
-/+ buffers/cache: 200 3850
Swap: 4102 0 4102

So there you have it, the command reports that I have 4,051 megabytes of ram. I’m not sure if that is the same idea that 10.3 had, but what’s few megabytes when you have a whole gigabyte back?

All I had to do was reinstall the pae kernel. Does it make sense… somewhere. Ha ha. Thanks for all the help, everyone. :slight_smile: