in MATE caja opens a lot of windows and everything become unusable

using MATE, at the login a lot (one every two seconds at least and they full the application panel) of caja windows are opened and the system result unusable.
how to avoid this and have again MATE usable??
manythanks, ciao :.) pier

I updated my 42.1/Mate just now and am not experiencing the problem you describe.

Googling your problem, I see results up to 2014 and skimming a few of them it looks like there can be many causes and people found many workarounds… But it’s unknown whether there is any “magic bullet” since there have been so many causes.

I suppose you should start with describing how you built your Mate in the first place.
I found that the only way I could create a likely fully working Mate is to create a 42.1/LXDE (I didn’t check, but it might be possible to start with an XFCE Desktop also), then add the Mate Desktop, then upgrade to 42.2.
Various other tries to install Mate directly into 42.2 instead failed for me.

Also, particularly if you didn’t install Mate from the OSS, you should state where your Mate came from, and whether you updated your system afterwards with the following command

zypper update


I installed mate from yast>software management and selecting patterns Mate base system and Mate desktop environment

That sounds like Bug 905808 - caja gone mad

However, that was fixed long ago, and I am not seeing it with 42.2.

I’m guessing that you have some non-standard repos and some non-standard package collections.

uh, may be, …but, is it possible to use MATE without caja??

I’m guessing that you have some non-standard repos and some non-standard package collections.
yes, non standard repo … :slight_smile:

yessss, it was,
doing this
Commenting out this line from it:

include /usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc
manythanks, ciao, :slight_smile: pier

I suppose yes (if the package dependencies allow it).

But you definitely won’t be able to have icons on the desktop, as caja handles that.
(like nautilus in GNOME2 on which MATE is based)

yes, non standard repo … :slight_smile:

Have a look at comment#5 in the mentioned bug report.
That seems to imply that one possible cause is the ~/.gtkrc-2.0 that KDE writes to make GTK applications use the theme settings.

So, your problem is likely caused by the fact that you used/use KDE, not by your additional repos…

Try to modify ~/.gtkrc-2.0 according to that comment, i.e. remove this line and see if it helps:

include "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc"

(or similar, depending on your KDE-GTK settings)

Note that I haven’t tried that because I don’t have MATE installed.
I remember seeing the same problem though when I did try it once in 2014 because of a similar forum thread back then (but I did not try this workaround then either as I didn’t want to use MATE anyway).

Or try to delete ~/.gtkrc-2.0 completely, but note that it will get recreated if it doesn’t exist when you login to KDE (unless you uninstall kde-gtk-config5).

When I was running 13.1, I used two version of “.gtkrc-2.0”. One of those was named “.gtkrc-2.0.kde” and the other was named “.gtkrc-2.0.mate”. And “.gtkrc-2.0” was a symbolic link to one of those. I had my shell startup file check environment variables to see what desktop I was running, and then switch the link as needed. That worked pretty well.

Unless your Mate Desktop looks like the following image when you click on the Application Launcher,
IMO you haven’t installed the Desktop properly