Impossible to make LEAP working on Dell Inspiron 7559

I got a brand new DELL Inspiron laptop with i7, 16GB of RAM and Intel graphics / NVIDIA Geforce 960M.
It was coming with an 128GB SSD and 1TB magnetic disk. I switched the magnetic disk to a 512GB SSD Samsung 850 PRO.
I wanted to install Linux and have only Linux on my laptop in order to have a fast and secure desktop and play and work with KVM.
It took me a headache and more than a day to figure out all the big problems that were freezing the installation and were making Linux unworkable.
At the end I completely disabled UEFI, nomodeset and APIC. Then I wanted to install NVIDIA drivers. Nouveau was freezing. Once I installed the NVIDIA drivers from the repository graphics mode was not starting at all. All I could do was to run root on TTY1.
I deleted nouveau, blacklisted it and then followed the NVIDIA the hard way wiki page but still the problem persists. NO graphics.
Some BIOS have options to disable built in graphics but not mine.
I tried to debug the issue and find further details but in the end I was getting error messages like " no screens found ".
I spent a lot of hours until 6:00 AM in the morning and eventually…I reinstalled Windows :’(.
Something is wrong here in the Linux Deskop guys. This shouldn’t be the case with Linux installations. Why so many bugs? Why so much effort to install Linux? It used to be the case that the only hard and critical stuff was partitioning. Then things were getting better? How did it come to this?
I also tried to install other distros like Ubuntu or Fedora but they were freezing during install or setup.

As far as openSUSE, I have one thing in my mind…BRING BACK sax! This was a fantastic tool and was getting graphics actually work in a breeze. Then mode setting came to the kernel and they abandoned sax. I used to run sax from run level 3, Xorg was configured and then once I was issuing init 5, graphics with NVIDIA graphics were immediately up and running.

Now I am stack with Windows until nvidia launches a new driver build and then I try again.

I am open to comments and discussions.

As a matter of fact is there a place where I can make a feature request/enhancement to bring back sax?
Where do I need to do it? Can you post me a link?

But I doubt that this will happen…

And sax won’t help you at all if your installed nvidia driver is not working.
Actually there’s no need to configure anything nowadays, the nvidia driver will be used automatically if it is installed.

/var/log/Xorg.0.log should show what is wrong…


I got a brand new DELL Inspiron laptop with i7, 16GB of RAM and Intel graphics / NVIDIA Geforce 960M.

This is likely a so-called “Optimus” system, so installing the nvidia driver won’t work as it doesn’t support such systems.
The system runs on the intel chip by default, and installing the nvidia driver breaks intel graphics.

Unless you cannot turn off intel graphics in the BIOS/UEFI firmware settings, you’d need to use Bumblebee to make use of the nvidia chip and driver.

Or use PRIME. a first step, uninstall all nvidia packages though to get the system running again (using intel graphics). You can do so with zypper or YaST (which does work in text mode too).