Impossible to change language [11.2]

After an installation, every time I reboot, the language and keyboard is set to english at the kdm step.
I change it in YaST>system language, it works. Then after reboot, it will be switched back to english.

Go Configure Desktop>Regional and language; the desktop settings are separate from the system settings.