Impossible to boot after trying an upgrade

Hello everyone,

I was trying to upgrade a Tumbelweed installation. During the upgrade (installation of packages), it crashed and ended up in a black screen whith a white “-”.
I had to force shutdown and start the laptop again. But now, I can’t do that, after the tumbelweed logo, it’s just a black screen with the same wihte “-”.

I tried using the kernel recovery mode, but still the same with the following screenshot (it just freeze there):

Is there anyway to try to fix this please? Thank you!

Several years ago, I had a broken system – not quite the same brokenness that you have – due to failure in the middle of an update.

I booted rescue media, and mounted my system at “/mnt”

I then used:

mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys

I then used a “chroot” session:

chroot /mnt
mount -a  ### mount everything else needed
exit  ### exit from chroot

This was to mount other file systems. In particular, if you are using “btrfs”, that will mount the subvolumes.

Then, at the upper level (without “chroot”), I attempted to complete the update.

I think I used:

zypper --root /mnt dup

and that got my system back into shape.

There’s no guarantee that this will work. The other option is to reinstall.

With the recent huge TW updates you may have run out of space

Thank you everybody for the answers. I solved the problem by doing the following:

  • On the black screen, I pressed Ctrl+ Alt + F1 to switch to Terminal (I think I was lucky, that only the graphical interface was messed up and not a system configuration)
  • Then since I couldn’t connect to Wifi, I just used connected to Ethernet through dhclient command
  • I used the upgrade command (zypper dup), the Terminal finished the installation of the missing packages
  • Reboot and it worked!

Thank you again!
(I’m sorry, I cound’t edit my first post to add the solution or to mark the thread as Solved).