impossible su - root

hi everybody
i try lo login root using su - root and password and i get the message:
authentification failure!!
i didn’t change my password and i may login root using a normal session with the same password!
what happens?
can you help me?
Many thanks

Not without more information.

  1. Which opensuse version;
  2. which desktop;
  3. what does “try to login root” actually mean? Are you doing this in a terminal session? Which terminal program?
  4. what does “normal session” mean? Is this a GUI login as root?
  5. What are the keyboard mappings being used? Maybe the keyboard is mapped differently for the two logins.
  6. Have you tried CTRL-ALT-F2 to get to a console text login session and have you tried a root login there?

And in answering all the questions above, remind that saying “I try to …” is only telling some story to illustrate the background. Please show also the facts by copy/paste what you did into your posts (between CODE tags of course, that is the # button in the tool bar of the post editor). People can normaly only help with technical questions when the technical facts are presented to them.

E.g. I would do

henk@boven:~> su - root
boven:~ #

which shows you and others how it works in my case. You should post likewise to show what happens in your case.

thanks for your answer:

here is the context:

opensuse 13.1
KDE desktop

i open a cp,sole login and do:

thierry@linux-laptop:/> su - root
Mot de passe :
su: Échec d’authentification

when i try to login through the desktop login windows or when i open another session with root it works.

i tried CTRL-ALT-F2 : it doesn’t work (same error)

So it’s only su that doesn’t work?
Have you tried sudo?

Maybe your su command has insufficient permissions.
What’s the output of this?

ls -l /usr/bin/su

It should look like this:

wolfi@linux-lf90:~> ls -l /usr/bin/su-rwsr-xr-x 1 root root 31744 15. Sep 09:19 /usr/bin/su

Judging from the response to the “su” command which is in French I suspect that the default keyboard is configured as French. If you add an English keyboard layout via Configure Destop>Input Devices>Layouts and switch to it using the bottom panel I believe your problem will disappear. You can toggle between the two layouts. I have the same problem with a Greek layout.


the result if ls -l /usr/bin/su is: -rwsr-xr-x 1 root root 31744 15 sept. 09:19 /usr/bin/su seems ok

i tried an english keyboard for the same result.
I just saw that 2 keys on my keyboard don’t work anymore :

the “right arrow” writes “h” instead and the “suppr” writes “—”
i have a problem!!!

Only those 2 keys?
Doesn’t look like a hardware problem though, I’d say.

Do they work after you run this in the terminal?

setxkbmap fr

Do they work in a fresh user account?

setxkbmap fr does nothing

some keys of my numeric keyboard don’t work anymore.

must i reinstall opensuse???
is it a hardware problem?


Who knows? Hard to tell over the internet…

Does it work in text mode?
Does it work on a fresh user account?

Do you have a different OS installed where you can try? If not, maybe use a LiveCD.

Run xev and see if it reports anything for those keys (and what).

PS: As you are now talking about the numeric keypad, have you pressed NumLock?

Possibly a bad keyboard? Do you have a spare one you can try?

i have more and more keys who don’t work anymore properly.
I tried another OS : Kali-Linux and i have the same problem.
An idea?

That sounds very much like a bad keyboard, however there’s a remote chance it could also be another hardware issue. Before you run out and buy a new keyboard try to borrow one for a quick test. If it works then buy a new one for yourself. If it doesn’t work I’d get really worried about your motherboard.