Impossible installation of openSUSE 11.4 on Toshiba Satellite A300-1RV

Hello all! I need some help here!

I tried to install openSUSE 11.4 from the live CD's both the KDE and GNOME 64 bit version. Unfortunatly both the installations fail.

The problem is due probably to the graphic card ATI HD 3650.

I tried installing it even with the only text type but after the loading of the kernel, I always get a black screen with a lot of colored lines, and the image doesn't get back.

After a while the hard disk stops and the installation freezes. I tried installing it with various options, and various 11.4 supports but i always get the same problem.

Can someone help me?

Thanks a lot


Can you tell us if the desktop loaded in live before intsalling ?

Hmmmmm. Check also your Hard drive disk maybe it has problem.

Thx for your replies. The HD is fine, i’m actually writing from the same PC on another Linux distribution.

The live cd gives the same problem when trying opneSUSE 11.4.

On 05/04/2011 03:06 PM, Matteo1982 wrote:
> The live cd gives the same problem when trying opneSUSE 11.4.

yours sure sounds like a graphic problem, did you try any of the advice

(just pretend the symptom given on that page is exactly what you see,
and then read all the way down to (to soak up the background) “The 1st
thing to try” and then try that…and let us know if it works for you

[openSUSE 11.3 + KDE 4.5.5 + Firefox 3.6.17 + Thunderbird 3.1.10 via NNTP]
HACK Everything →

Toshiba’s are well known to have problems with some Linux distributions.
Especially if your rig uses the Insyde Bios.
(you will see the Bios tag in the bottom left corner of your screen just after you power up the machine)
I know about the bios problem because I own one (An L505)
I don’t know if you get to the OpenSuse splash screen,
but if you do type into the text box


and see if that will let you boot,
most of the time the kernel will find an Insyde bios and set this for you.
But sometimes it does not happen, so you must do it for it.

Also there is a “nomodeset” command that may help,
but you will need look around to find out how to set it up.
I don’t remember off the top of my head how it works.

On my Dell Studio 1537 with Radeon HD 3450 graphics, I obtained the same behaviour with the openSUSE-11.4 liveCD. I wrote a bug report on this.

What DID work was to boot with the boot code ‘nomodeset’ which would force the loading of the ‘radeonhd’ driver which works with the Radeon HD3450 (and likely works with the Radeon HD3650). After doing that, one can then edit the /etc/X11/xorg.conf.d/50-device.conf file, uncommenting the

  #Driver "radeon"


  Driver "radeon"

and then save the change and reboot with the boot code ‘nomodeset’.

I also noted the boot code ‘x11failsafe’ (which forces FBDEV graphic driver loading) worked.