Impossible de démarrer Windows après installation d'OpenSUS

Bonjour,
J’ai essayé toute les manip’ que je connaissais et celles que j’ai pu trouvé à travers mes recherches alors j’espère qu’expliquer précisément mon problème pourra m’aider.
Voilà, pour le besoin de mes études, j’ai du installer OpenSUSE. N’ayant pas de CD/DVD (jusqu’à aujourd’hui), j’ai utilisé une clé USB pour booter l’image disque et installer OpenSUSE. Ici commence les difficultés…
Depuis cette installation, aucune trace dans le bootmanager de OpenSUSE. Seul Windows est encore présent. Seulement lorsque je laisse Windows se démarrer, je peux choisir de lancer le Réparateur de Système ou de Démarrer Windows normalement. Quoique je fasse, il tente de lancer le réparateur de système et échoue et retourne sur l’écran de sélection.
J’ai utilisé ma dernière carte en supprimant les partitions que j’avais réservées à OpenSUSE, formattant ma partition Système afin de réinstaller Windows… L’installation est un succès mais ça ne résoud en rien le problème…!
Autant vous dire qu’actuellement, je souhaite en priorité récupérer un Windows fonctionnel…

Voilà. Je ne sais pas trop quoi vous donner pour m’aider. Je tourne actuellement en mode Rescue sur OpenSUSE, mon ordinateur est un ASUS G75VW.

On 09/26/2012 07:16 PM, Roms17 wrote:

> Bonjour,

-=WELCOME=- new poster!!

technically you can use any lingo you wish here, but there is a French
language forum listed here: http://forums.opensuse.org/forum.php (scroll
down a little)

sometimes when i have the spare time i will run such as yours though
google translate and see if i can figure it out…but, not
tonight…maybe someone else will :slight_smile:


dd

Oh. I’m sorry. I don’t know how I posted in the English forum… Well, I can’t find how to edit my message either so I’ll just translate it.
So hello, and here’s my problem… : I used to have Windows 7 64bits installed on my computer. I tried to install OpenSUSE but it never appeared in my bootmanager… Worse : it messed up my Windows installation : at boot time, it displays the Windows Repair Manager and can’t boot or repair.
I tried reinstalling Windows but it changes nothing… I also uninstalled OpenSUSE.
My top priority is get a working Windows back… I’m on rescue mode for now. My computer is an ASUS G75VW.

Je te répondrai quand ce fil de discussion aura été déplacé dans le forum français.

Please move this thread to the french forum. I will reply there.

OK. So if you can read english and if it’s a UEFI system, you’ll find all answers and finally the solution in this thread: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/478260-trouble-dual-booting-12-2-windows-7-efi-enabled-system.html.

As it seems that the OP only choose the wrong language but not the wrong forums and he now reverted his error, we will leave this here abd I hope every poster from now on will try to use English.

(I am a happy man, not having to move again, I do not know what glasses these French people use :wink: )

(I’m sorry Monsieur le Moderator :slight_smile: I should be okay though)

Thanks please_try_again, so I’ve tried to follow the guide but I can’t seem to be able to install windows on the partition anymore : it tells me that the partition is not fitted for Windows (either because it is not a GPT Partition - I’m not sure - or because it’s not in the MBR). I really don’t know how to fix this since the DVD worked just yesterday.
My disk is partitioned into 5 : a 200mb in fat32, an empty OS partition (300gb), a DATA partition (410gb), 18gb of free space (used to be where OpenSUSE was installed…), and the Recovery Partition (of 27gb). Don’t know if these information can be useful…

Boot any live Linux DVD you have, do “fdisk -l” and “parted /dev/sda print” and paste output here in code tag.

here are the outputs for :
fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.
Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x527cd163

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1      411646      205823   ee  GPT
Partition 1 does not start on physical sector boundary.
/dev/sda2       586731520  1376925695   395097088    7  HPFS/NTFS/exFAT
/dev/sda3      1412718592  1465147391    26214400    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 8076 MB, 8076132352 bytes
64 heads, 32 sectors/track, 7702 cylinders, total 15773696 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x32f15c08

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          64     1392639      696288   83  Linux
/dev/sdb2         1392640     5586944     2097152+  82  Linux swap / Solaris

parted /dev/sda print

Model: ATA ST9750420AS (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt_sync_mbr

Number  Start   End    Size    File system  Name                  Flags
 1      1049kB  211MB  210MB   fat32        EFI system partition  boot
 3      345MB   300GB  300GB   ntfs         Basic data partition  boot
 4      300GB   705GB  405GB   ntfs         Basic data partition  boot
 5      723GB   750GB  26,8GB  ntfs         Basic data partition  diag

(thanks for your attention)

Yes, you have to blank the mbr and the GPT headers. I usually wipe out the first track.

from a linux live cd:

$ sudo dd if=/dev/zero of=/dev/sda bs=512 count=63

Then you can install Windows, fix the MBR from a linux live CD (as explain in the other thread - read carefully ) and reinstall openSUSE.

You should not use the openSUSE partitioner with a Windows protective MBR or it will convert it into a hybrid MBR, with the consequence that Windows won’t boot anymore.

No, just replace it with protective MBR:

gdisk /dev/sda
x
n
w

It should work now. If not, it is always time to reinstall. You can install gdisk in openSUSE using “zypper install gptfdisk”. Double check that it is the right HDD with Windows. If you do the same for second disk with openSUSE, it will be unbootable too …

But I am surprised that the second disk is actually MBR. I would not expect it on UEFI system … or legacy boot was selected to boot openSUSE installation DVD.

It believe that @wkolar didn’t try that in the other thread because it should have worked:

Look at the size! It’s a USB stick.

Well, it depends if we’re talking about reinstalling WIndows or reparing it. If you’re going to reinstall it, blanking the first track is just fine. If you only want to be able to reboot it without reinstalling, fixing the MBR is the right way to go.

Okay, so I blanked as please_try_again advised me to, and then reinstalled Windows : it now works perfectly, thanks!
I’ll just follow the guide for OpenSUSE hoping I won’t encounter another issue.
Thank you.