Import vCalender into KDE-Calendar -> error message

OS: LEAP 42.2 (but I think, it is not relevant for the question)
KDE Plasma: 5.8.6
KDE Frameworks: 5.26.0
KOrganizer: 4.14.10

I thought , it was simple to import vcs-files (appointments) into KDE-Kalender (KOrganizer)
I tried in different manners, but I get always the same error message

Failed toload ical file, check permission

or none of new “imported” appointments is displayed.

But the permissions of the vcs files, I want to import, is ok:


Is it no more possible to import vcs files in Korganizer?
What can I do without cloud services? (I don’t trust any of them)


  1. From the menu → Files / import / import calendar
    then, after one vcs file is selected, a dialog box with two options come on
    if I choose *join in existing calendar * , I get the above mentioned error message
    if I choose add as new calendar, a new calendar resource has been added but not the appointment in it.

  2. right mouse click on the resource list in KOrganizer (or through configure Kontact)
    The Add Calendar window pops up - No way to select a vcs resource type
    Then, if I choose ICal calendar file, I get the same error message
    if I choose ICal Calendar directory, I get a new empty calendar added

  3. The same as in point 2 happens working on akonadi console

about the vcs files
each of them is a distinct appointment, exported by a android calendar on smartphone
Structure of thees vcs files - an example

SUMMARY;LANGUAGE=de:Alden WG 5  13:00
LOCATION:ARP Sud -> Georg-Hirt-Str 71, 73700 

You may be correct with your conclusion about that permission, but what you show does not prove anything (and thus you could have left it out for the same effect). It only shows part of what I guess is a line created by an ls command. We see that owner can read and write and group can read, but we do not see who is the owner or what is the group. We also do not know if the user executing the import is the same user or belongs to the same group. There is also no prove that the directory where the file belongs to has proper permissions for the user.

While even posting a complete copied/pasted prompt with command, output, next prompt sequence of an

ls -l

will not reveal all of the aspects I mention above, it is, as in most cases, better then such a tiny part of information.

Again, it may not be the cause of your problem, but we can not come to any conclusions based on what you show here.

Hi hcvv,

First of all, thanks for replay!

Yes, you are definitively right with your statement and I thought, it is obviously the owner of the files is the same of the used Korganizer. Otherwise I did not checked it …
However here is the complete permission information. So a problem cause can be definitively excluded.

geppino@dhcppc0:/DOCS_A/ORGA/PIM/Smartphone-PIM/Smartphone-Kalender> ls -l
insgesamt 32
-rw-r----- 1 geppino users 480  4. Jan 18:09 Alen 8592952.vcs
-rw-r----- 1 geppino users 452  4. Jan 18:09 Alen 8592953.vcs
-rw-r----- 1 geppino users 478  4. Jan 18:09 Christopher 8592950.vcs
-rw-r----- 1 geppino users 376  4. Jan 18:10 Freizeit?.vcs
-rw-r----- 1 geppino users 479  4. Jan 19:53 Susanne WG5.vcs
-rw-r----- 1 geppino users 509  4. Jan 18:10 Suzan 8591376.vcs
-rw-r----- 1 geppino users 467  4. Jan 18:10 Suzan 8591377.vcs
-rw-r----- 1 geppino users 459  4. Jan 18:10 Suzan 8592930.vcs

Another Information - I don’t know, how important it is:
the files has been transferred per blue tooth

My perhaps pedantic post was not only to point to the value of your information, but also because my experience is that when a program says there is a permission problem, this most often points to a permission problem. And thus jumping over it lightly is perhaps not a good idea.

Thus digging a bit deeper here might be of use.

I see that this is not inside geppino’s home directory. Thus checking the path from /DOCs down to the file wouldn’t be bad IMHO. And is /DOC a mount point? Probably a non-Linux file sytem?

I also see that file names there have blank spaces (and one ?) in their names. That should of course not be a problem in general (when you do not forget to quote in the shell), but some programs are badly programmed in this aspect.

Just a thought.

In other words, you’ve imported the appointments from your SmartPhone via Bluetooth.

  • Presumably, you’ve exported the appointments from your SmartPhone calendar.
  • You’re using KDE Plasma 5; Kontact; KOrganizer.

Just a suggestion:

  • Install the KDE-Connect app on your SmartPhone;
  • Connect the SmartPhone to a WLAN which is also accessible to the openSUSE system;
  • Pull the exported SmartPhone calendar appointments over to the openSUSE system with (KDE) Dolphin;
  • Re-try the import into KOrganizer.

An Android phone and you think you’re not using cloud services? Or do you use some custom ROM without any Google connection ?

IMHO manually importing is unreliable, but more from a user perspective. Forget once and you’re out of sync.

Did you try changing the permissions, try copying the files to your homedir?

And, indeed, what Henk says about the spaces and the question mark in the filenames.

One of the problems in debugging this is IMO that the error message is far to vague. With a little bit more effort of the programmer, the message could have contained the proper file name and what permission (read, write, execute) is blocked. Yes, software quality vs. speed …>:(

[INDENT=2]**ERROR # (undefined)
WARNING: Something on your computer failed to do something.

One more remark, but I am getting more and more on softer ground because I am still using a very old KDE PIM suite. Mainly because of problem using VCard directories as address books.

Newer Kontact try to add a file to a directory with VCard address files. Thus such a directory must also be writable for the user. When this is a relate case,


should at least have as owner geppino and rwx------.

A simple check if geppino has permission to read and write would of course be by geppino editing one of those file with a simple editor. That would rule out suspects as the blue tooth connection (which I do not blame, after the transport there is no metadata connected to a file that says: it was created in such and such way).

As a Leap 42.3 user with default Leap 42.3 KDE Plasma 5, Kontact and KOrganizer, my Appointments, Activities and Journal ** directories ** are stored as follows:

 > l -d .local/share/korganizer
drwx-----T 16 XXX users 254  2. Jan 09:19 .local/share/korganizer/

a lot of questions … and I don’t know, where I should begin with.

First of all, many thanks for the interest !!!

Meanwhile I’ve compared a simple iCal file with a vCal one and experimented with them, obtaining following conclusions:

1. After added a line into the vCal, which I think as typical in iCal structure, than KOrganize can import the “changed” vcs.file.
Added line


BTW I also tested with “VERSION:2.0”.
So it is sure:
a) the question has not at all to do with permissions and
b) the error message is undefined (no vCal data import implemented?)

2. Even with the add line the vcs file is not correct imported - Day is right, but not the start and end times.

These two results let me think, KDE PIM (at least the version 4.14.10) cannot handle with vCal file.

I apologize but I will not reply posts about

  • the structure of my Linux System (in my opinion these are not problem solving oriented, and yes it is possible to sync manual extracted data with a little bit fantasy and cleverness)
    • or my behavior with smartphone and internet. I only say, I don’t need internet connection with smartphone and I don’t trust Google & co. Is it so strange?

For my side we can consider this thread as closed.

Thanks again for your interest!

I think the best way to go here is trying KDE itself.

There is the KDE forum:

And there is the KDE PIM mailing list:

This may be something which got fixed with the KDE Plasma 5 version of KOrganizer – you’ll need to wade through the Bug Reports and changes made between version 4 PIM and the current PIM.

I have KOrganizer version 5.5.2 here. Maybe I’ll take a look at exporting some Nokia 3 appointments to this system sometime later this week – it’ll be a real test because, I actually don’t have any appointments on that SmartPhone at all, for the Google account reasons mentioned below. But, I’ll create a couple of dummy appointments to see what happens.

Having searched for a Google description of exporting the appointments from their Google Calendar running on an Android (mobile) telephone, I’ve come to the conclusion that, this can only be done by running the Google Calendar on a PC (assuming that, the appointments have also been stored in the Google Cloud) and then in the Setup menu there’s an option to export the entire Calendar to a .zip file.

Or, one has to install an “Export/Import ICS files” App on the telephone.

So, exactly, how did you export the appoints on your telephone as ICS files?

  • I did see some rather old information, which indicated that, the Google Calendar running on an Android telephone uses (still?) an SQL database to store things such as appointments – therefore simply connecting to the telephone via KDE Connect to simply pull the appointments as native Google files to the KDE machine will possibly not work.