Implement Static DNS IP addresses Leap 42.1

Hi,

I have seen another thread on DNS entries added to config in /etc/sysconfig/network/, but i am not sure how to ensure that they appear in resolv.conf.

I have not used Network Manager to create a connection, as i rely upon the system to create the connection dynamically when i plug in the network cable.

As such - the system always uses DHCP and dynamic DNS entries from the router/modem of the ISP.

I have had so many issues with the DNS response where suddenly the response is that there is no entry for the url sent despite it working a few moments earlier.

I have added the list to :

NETCONFIG_DNS_STATIC_SERVERS
NETCONFIG_DNS_RESOLVER_SORTLIST

Yet this does not create in resolv.conf dynamically.

If i wish to continue to plug in the ethernet cable only when i need to surf the internet, how do i ensure that the resolv.conf uses my list and not the DHCP ip address response ?

Thanks and regards,

Shadders.

I’m not currently using wicked on my main laptop, but I note that the opensuse guide mentions

To disable DNS configuration using netconfig, set NETCONFIG_DNS_POLICY=‘’. For more information about netconfig, see the netconfig(8) man page (man 8 netconfig).

so perhaps you need to change

   NETCONFIG_DNS_POLICY='auto'

to

   NETCONFIG_DNS_POLICY=''

then restart the network

systemctl restart network

This might also be sufficient (following any DNS config changes)

netconfig update -m dns

Hi Deano,

Thank you for the reply - i will try that.

Regards,

Shadders.

Hi,

OK - the search using the the default network address is now missing - but a nslookup produces no results - so DNS not working.

Is there another setting i must use ?

Or is it easier to create the connection manually and set the DNS in that network connection ?

Thanks and regards,

Shadders.

You have a couple of options:
Use YaST’s network module. Set it to use wicked, add f.e. 8.8.8.8 and 8.8.4.4 as the DNSs, your router IP as the gateway. Or set the same module to use the Networkmanager and
Use the Networkmanager settings app for your desktop environment. These allow manual/static configuration as well.
Use an editor and make this part of resolv.conf


### Please remove (at least) this line when you modify the file!nameserver 8.8.8.8
nameserver 8.8.4.4

look like this when you manually want to enter data without it being overwritten


nameserver 8.8.8.8
nameserver 8.8.4.4