iMac Sound issues


I am a new user on openSUSE and linux altogether. I have an iMac model number A1224 and I can’t seem to get my sound working. I have tried messing with ALSA in terminal and sound checking in YaSt and I am having really poor luck. Any help would be greatly appreciated.


You could try working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Also, please note that to determine if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times.

If you have no success with the audio troubleshooting guide, then I will need more information if I am to make a recommendation … So can you provide more very detailed information so a good recommendation can be given? You can do that, with your iMac connected to the internet, by opening a gnome-terminal or a kde konsole and typing:
/usr/sbin/alsa-info.shthat will run a diagnostic script and post the output to a web site on the Internet. It will give you the URL of the web site. Please post that URL here. Just the URL. It may be that you need to run that script with root permissions. Please note that I need that output to understand better your iMac’s configuration.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/soundHopefully with those output (script plus result of commands) I can make a good recommendation.

this is the address it gave me and here are the outputs for the other ones.

Stephen@linux-qugk:~> rpm -qa | grep alsa
Stephen@linux-qugk:~> rpm -qa | grep pulse
Stephen@linux-qugk:~> rpm -q libasound2
Stephen@linux-qugk:~> uname -a
Linux linux-qugk #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux
Stephen@linux-qugk:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.2frKzjmhZt4:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

By the way, I have tried the troubleshooting and speaker tests to no avail. I forgot to mention that.

OK, that tells me your iMac has an ALC889A.

Hmmm … I can not see any indication of the troubleshooting guide being attempted … One of the early recommendations of the troubleshooting guide is to install alsa-firmware, but I see no evidence of that install in your previous post. Did you install it and remove it? Please install alsa-firmware. Then restart your iMac, and test your audio. And for now leave it installed. I do not know if your iMac requires it, but for the time being, until sound is established, I believe it to be a good idea.

I looked at your mixer settings, and they appear ok for testing.

I saw no mention of the ALC889A in the ALSA-Configuration.txt file for 1.0.18 of alsa. I searched for the ALC889A on the alsa web site, and I did note a series of updates made between 1.0.16 and 1.0.18 of alsa. In particular here: Changes v1.0.16 v1.0.17 - AlsaProject I noted this comment:

ALC889A is recognized ALC885/ALC882 but it's actually closer to ALC888/ALC883

It is possible to apply model options for the ALC885/ALC882 and ALC888/ALC883 codecs.

These options are listed here (from the ALSA-Configuration.txt file):

	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  arima		Arima W820Di1
	  targa		Targa T8, MSI-1049 T8
	  asus-a7j	ASUS A7J
	  asus-a7m	ASUS A7M
	  macpro	MacPro support
	  mbp3		Macbook Pro rev3
	  imac24	iMac 24'' with jack detection
	  w2jc		ASUS W2JC
	  auto		auto-config reading BIOS (default)

	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  lenovo-sky	Lenovo Sky
	  haier-w66	Haier W66
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  clevo-m720	Clevo M720 laptop series
	  fujitsu-pi2515 Fujitsu AMILO Pi2515
	  3stack-6ch-intel Intel DG33* boards
	  auto		auto-config reading BIOS (default)

So lets assume the alsa autoprobe upon boot did not recognize the appropriate model for your iMac, and lets try some (all ? ) of the above ONE at a TIME, to see if any help.

So please edit your /etc/modprobe.d/sound file to be as follows:

options snd slots=snd-hda-intel
options snd-hda-intel model=imac24
# u1Nb.2frKzjmhZt4:82801H (ICH8 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and restart your iMac’s alsa sound driver by typing in a konsole/terminal su -c ‘rcalsasound restart’ enter root password when prompted, restart your mixer, and test your audio with the speaker test I recommended in my 1st post.

If “imac24” does not work, then try each of the options listed in the above, one by one, until you find one that works. For example, to try “3stack-dig”, replace “imac24” in the /etc/modprobe.d/sound file with “3stack-dig”, restart your alsa sound driver, restart your mixer, and test your audio.

Do that for each model option in the list, until one provides sound.

thanks for your help. I will try those and see what happens. I thought I had installed the alsa part in my computer but i did reinstall linux at one point in trying to solve the issue to get a clean start. I may have done the troubleshooting on the previous installation.

Again, I will try what you have suggested and post my results. Thanks :slight_smile: