iMac install - Get Blank screen issue

Just downloaded the latest installer for PPC

Boot from the disk and get the prompt to type “install” to start the yast installer from the DVD

I do few things scroll by and than a black screen amd remain stuck there.

Its a gooseneck imac i believe its 1.24ghz system i am not to sure what to do on this one.

so i spotted this thread opensuse11- Install - black screen/blinking monitor- fix !!! - openSUSE Forums

and its dam close to my issue and the only prob is im not too familiar how to apply the fix

Load up DVD,

  • on the initial grub screen press Esc
    → you should be in normal text grub (i.e no pretty green graphics…)

  • go to suse install entry in grub

  • press e (to edit)

  • go to the kernel line (press e)

  • I added vga=795 at the end of the kernel line
    (vga=795 = 1280x1024)

  • after that it installed fine

I can confirm that the vga=795 did make the difference, after the successful installation, I retried to install without the vga=795 option and it again failed (blank screen,etc) - after doing it again with the vga=795 option it installed fine.

If your monitor is not capable of doing 1280x1024 then try vga=791 (this is - 1024x768)

I hope this helps somebody…

They should really fix this ASAP…

Grub screen is? the text screen you type install at? tried these steps from there and no luck…

if i type install it goes black… if i try esc from there nothing…

::bump:: any luck?

I don’t know about PPC version but the x86_64 one they used does not require you to type install anywhere, the DVD boots to nice, green menu, which actually is GRUB, graphical version. To revert back to text mode GRUB you press ESC. I have seen other installers, which boot to LILO: prompt and instruct user to type ‘install’. If you have lilo then you don’t have grub on that DVD. If you in fact do have LILO: prompt, this is probably the place to pass additional parameters to the kernel, like the vga=791 thing. I think (no lilo experience, just googled) you could try “install vga=791” instead of just “install”.

I don’t know what you mean by the “text screen you type install at”. The GRUB screen should be what ever screen you choose the OS to boot into. Are you dual booting OS X and openSUSE? If so, you should have both a Apple boot screen (I forget the name) and, if you choose “Linux”, you’ll get the standard “GRUB” screen.

Anyways, to follow the directions you have, you need to hit the ESC key at the GRUB boot screen (on openSUSE, it’s a nice green themed screen, usually with two bootup choices by default;

openSUSE 11.0
Failsafe - openSUSE 11.0

If you’ve installed more kernels they’ll be listed there too).

I have the same iMac, and inconveniently the same problem. What happens is that holding option after restarting the computer comes lets you choose to boot with Mac OS X, or Linux. After that it comes up with three options on a black screen. One is to install using YaST on the CD/DVD, (I’m not sure but I believe two and three are) Two is to Install using YaST on a Network, and Three is to restore the data. Once you type install it produces some code, goes to a black screen, shows a white screen for a second and then goes black.

Have you tried installing via text-mode ie,

install textmode=1

This might help bypass some of the more finicky video issues until you reboot. At least you’ll be able to get the system on the disk before hitting any other issues. hopefully.

And unlike x86 boxes, mine seems to be using lilo as a bootloader, and not grub. (formerly on Debian it was yaboot, but that’s another story.)

After a few years of helping get PPC macs online with Debian / Ubuntu, I was really pleased at how well OpenSuse works on my G5 iMac, so I’m interested in getting more ppc’s online with OpenSuse as kind of a thanks to the OpenSuse devs…