I'm not being asked to login

Hi all,

I’m a new adopter of OpenSUSE and selected Tumbleweed/KDE. So far so good and I’m enjoying the change, it feels fast and well put together: one (important) thing is rankling me, though, which is that I’m not being asked to login or, to clarify, I can login but am not being asked for my password.

If I shutdown or reboot, for instance, when the system comes back up I am back in the KDE Plasma shell with access to my files etc etc without having to enter my password. If I log out and then shutdown, same thing. The only time I am actually asked to enter my password is if I logout and then log back in (without powering down or rebooting in-between). This seems odd and I can’t help but think I’ve missed a setting or something (though I’m not sure what, exactly).

Things I’ve poked at:

  • In Settings > Account Details > My User
    I have checked that “Log In Automatically” is not checked. - In Settings > Startup & Shutdown > Desktop Session
    I have selected “Start with an empty session”. - In YaST > Security & Users > My User
    I have checked that “Disable User Login” is not checked.

tl;dr I want to have to enter my password after rebooting. What am I missing?

Thanks for any help!

So you have ‘Auto Login’ enabled in KDE? Check KDE System Settings > Startup and Shutdown to disable if desired.

Auto-login was the answer, thank you!

I did look at System Settings > Startup & Shutdown initially but I guess I missed the setting (going back, I see it now). Right before checking back here I did actually find a different path to resolution, though, which was via YaST > User & Group Management > “Me” > Expert Options (Dropdown) > Login Settings. Not sure if there’s a downside to doing it that way, but it seems to have worked :slight_smile:


Great result. Enjoy openSUSE and welcome to these forums as well. :slight_smile: