I'm Getting Tired Of This

Yesterday my copy of 11.0 updated its self. There were two updates, one of which was the kernel.

I downloaded, installed and restarted, and now my openSUSE won’t boot.

This is the third time that this has occured.

I tried to repair with the DVD, but that doesn’t work. I tried to rescue with the DVD, but that opens into runlevel3, and when I log in as “root” it gives me a prompt ending in ~# that I don’t know any commands for.

I don’t keep anything important on this computer, so the biggest pain is losing my Thunderbird email address book.

Why this happens, I have no idea. Can anyone talk me through the rescue? Or should I just reformat and reinstall as I have done in the past.

Home made system

Gigabyte GA-MA69G-S3H
Athlon 64 5200X2
2GB Crucial
WD 250 GB 7200
WD 80 GB 7200
Thermaltake 550 Watt

Maybe your graphics card needs to reconfigured. Boot to runlevel 3 Log in as your user not “root”. At the commang prompt enter su then your root password. now you will have root level access. Enter sax2 it will configure your graphics card. After you exit sax2 type reboot to restart the computer.

If it still boots to runlevel 3 type startx and list any errors here.

hope this helps

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Well I don’t know necessarily how best to fix the root cause but losing
your data isn’t something you should need to do in any case. The default
partitioning for SUSE involves keeping /home in its own partition so a
complete reinstall just involves replacing the / data and leaves /home
intact which means Thunderbird, when installed, will just work as you left
it. Backing up your Thunderbird data specifically is usually pretty easy
though getting the data off your system will be up to you (USB drive,
network-accessible something or another, etc.).

cd ~ #change to your home directory
tar -zcvf /tmp/thunderbirdBackup-date +%s.tgz ./.thunderbird*

When this command returns you should have a compressed file in /tmp named
/tmp/thunderbirdBackup-somethingHere.tgz which you should copy off the
box. Backing up your entire home directory is probably also a good idea
from time to time though any refinement you can do in those backups to
save space will probably be appreciated by you later on.

Good luck.

Masterbuilder wrote:
> Yesterday my copy of 11.0 updated its self. There were two updates, one
> of which was the kernel.
>
> I downloaded, installed and restarted, and now my openSUSE won’t boot.
>
> This is the third time that this has occured.
>
> I tried to repair with the DVD, but that doesn’t work. I tried to
> rescue with the DVD, but that opens into runlevel3, and when I log in as
> “root” it gives me a prompt ending in ~# that I don’t know any commands
> for.
>
> I don’t keep anything important on this computer, so the biggest pain
> is losing my Thunderbird email address book.
>
> Why this happens, I have no idea. Can anyone talk me through the
> rescue? Or should I just reformat and reinstall as I have done in the
> past.
>
>
> Home made system
>
> Gigabyte GA-MA69G-S3H
> Athlon 64 5200X2
> 2GB Crucial
> WD 250 GB 7200
> WD 80 GB 7200
> Thermaltake 550 Watt
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQIcBAEBAgAGBQJKMGxIAAoJEF+XTK08PnB5rYgP/R1orpJiY503Ifukrtdiuju2
aIsRypMUB4yXaCFQqTomhx+vJwkYOhql/eZwAjUH+GoUcNg8DM2JEWyRKqouz9cF
zxg4BEzhJZ1cOSNs51I55Y9o2gz6mp0qigNZTxSFMtD9TzOGIxGCz/VyK8r3brgq
OpHeBfQGAlODRxzppGOJakfddeZ9rexRwy4EMk/uHt/6Xv38MSIs/95yiQyif5Ee
qDHSGylmOZtWq7mXStnTjBl5O9Emnuru+IWISlmD6dGZQGs/f/OUezsel4ohLf95
X3/kQNmQ8RUFotnDRttebeLibloCC8VwthLcg1rTn6D/K1dYLY1oUy/+7bD7Gh8I
KJAdvlJzh82KLd+uslHvKFKvLe7Dl75U6ens/7oIXYWPiMe/ccky+TQ15a02LaDf
ly6zTjipbkuFPkO7B6QxKd8BAV+fiUm6c+3z8N9Bm5zUEmMVe7D+I3iQK8SkDgYm
FLhiXsU7XE+hutlcaXGPgHoNOzQ1KCJJaK93dPVJmxRfpWGXnLSN9dxk/teBzX7u
cUnpZ0NlSZ1rJhr4JLR4kU6i44NTp3lhucjjq8VPVu5S9MYWXwmo9JofaVQv+wyo
C8qSOh3XwZIfdpkfGaSKBWz3YOMtsPmbNMUamtslAtETP5sM32JZdL9zVg/DuBli
p8017DLZwiMFc8lw5aCY
=KyxS
-----END PGP SIGNATURE-----

Hi Masterbuilder,

I have had the same problem as you, and was able to recover from it fairly painlessly, so I am going to take a stab at helping you through this.

As with you, after each kernel update I get a black screen after booting. After panicking about loosing my data, and having formatted (Like you) the first time I went in search of a better solution.

It turned out for me, and for a few others I have seen on the forum, as harrylanza mentioned in his post, that it is the graphics card drivers that are the root cause of the problem.

Ok, so how do you fix this?

Two solutions… The easy quick fix and the proper solution! The easy way out of this is to set your graphics card to the standard VESA, and boot up into opensuse once again.

To do this:

During the boot process, at the Grub boot splash screen, before the timer runs out, type “init 3” and press enter.

This should log you into console mode.

Log in as root. Root is the su user if you aren’t sure which password to use…

Now type:

sax2 -r -m 0=vesa

Now type init 5 to get back into opensuse GUI. Note that this will not give you any 3D capabilities, and you will need to fix you graphics properly anyway if you play games on the box or if you use Compiz…

So now the propper solution…

During the boot process, at the Grub boot splash screen, before the timer runs out, type “init 3” and press enter.

This should log you into console mode.

Log in as root.

Now the next step is f vital importance… We need to determine what graphics card you have in your system. Because you said in your post that it was a “Home Made System” I will assume that you have a fairly decent graphics card in there, so it will probably be an ATI or nVidia graphics card.

To check, type: lspci

Look for the line VGA compatible driver.

Whatever the brand, the next step is the same. Download the driver from the manufacturers website.

From terminal the easiest way to download (In my opinion) is to use wget. To do this, type:

wget and the url that you want to download. Basically browse to the manufacturers website from another PC, find the driver, and on your linux box type in the URL for the file you need to download.
Example:

wget http://us.download.nvidia.com/XFree86/Linux-x86_64/185.18.14/NVIDIA-Linux-x86_64-185.18.14-pkg2.run

or

wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-9-3-x86.x86_64.run

Once you have downloaded the driver, you need to create a patch for the kernel to use the new graphics card driver.

To do this we need to resolve dependencies…
Type:

zypper in kernel-source gcc make patch

Once that is done, we need to install the downloaded driver.

Firstly check the downloaded drivers name.
Type: ls

I have an ATI graphics card, so mine is listed as:
ati-driver-installer-9-3-x86.x86_64.run

Now run the driver with the following command, and be sure to agree with everything and use all default settings. Don’t use the Distro specific build for ATI…

sh ati-driver-installer-9-3-x86.x86_64.run
(Replace the ati-driver-… with the version you downloaded)

Once you finish that type the following.

For ATI:
aticonfig --initial -f

Now type

sax2 -r -m 0=fglrx

This should take you into the sax config setup. Agree and save.

Type reboot to reboot…

For nVidia:

sax2 -r -m 0=nvidia

Done!!!

Now when there is a future kernel update, all you need to do, is log into init 3, and type the vender specific commands to get back up and ruinning in 2 minutes…

ATI:
sh ati-driver-installer-9-3-x86.x86_64.run
aticonfig --initial -f
sax2 -r -m 0=fglrx
reboot

nVidia:
sh NVIDIA-Linux-x86_64-180.22-pkg2.run -K
sax2 -r -m 0=nvidia

Hope that it works for you.

Dredger.

Dredger… I love you.

I tried so many ways to fix this, of my own devising and others. Yours was the one that worked! Thank you.

Always a pleasure…

I know how frustrating it can be to boot up in the morning and have a black screen awaiting you. Then needing to spend the next few hours trawling the forum trying to get the correct answer before you can get back to work can be rather taxing on one.

Glad that you found yours.

Dredger.

Dredger (et. al.):

Thank you, but this is not my problem. My problem is that openSUSE will not boot at all.

I turn on the computer, the boot loader comes up, I select openSUSE and I get ERROR 15. I select failsafe openSUSE and get ERROR 15. I select Mint and get Mint.

The only way I get runlevel 3 is with the DVD and the rescue mode.

Mint won’t let me access the /home folder due to permissions. If it would and I could copy the folder to Mint that would help a lot.

Thanks for your interest. I’m still stumped::.

Dredger…

̈́’Real teachers don’t ‘teach.’ They provide learning opportunities’

job very well done…

What happens if you run mint, open a terminal, and run


gnomesu nautilus

or perhaps


gksudo nautilus

?

[Please be aware that this will open a root file manager, with which you can do lots of damage. Pay attention to what you’re doing]

If this lets you access your files, if you can get to opensuse’s /boot/grub/menu.lst and copy it here (along with the output of ‘fdisk -l’ from mint’s terminal), it might make it clearer what’s going on.

Grub error 15 means it can’t find the kernel file. Something must have gone wrong during kernel update. Did you try with the suse dvd to fix it? Also this may help GRUB error 15 - LinuxQuestions.org

I should mention that openSUSE is on one HDD and Mint is on the other one. I’m at work right now, so I can’t try it.

I’ll try when I get home and let you know if nautilus will let me navigate the SUSE HDD.

When I try to repair with the DVD, I get messages about using a different version of openSUSE than the disk. Could it be that the upgrades SUSE has done over the months have rendered the DVD obselete?

If all else fails and you need to back up your data use a live cd of Puppy linux. it will mount just about any drive no matter what the file system.

The Puppy can be found here!
Home Page | Puppy Linux

The problem is probably with your grub control file, which is /boot/grub/menu.lst (that is an “l” not the numeral “1”). You are getting the grub menu from menu.lst, and the entry for Mint is working. Therefore its likely that the stanza for openSUSE is broken. Try this:

Boot the the grub menu. Hit the Escape key to drop the graphical menu into text mode. At this point, you can do one of two things: First, you can highlight the openSUSE line and hit the ‘e’ key; you are now in grub’s mini editor. Here you can edit each line (the commands are explained on the screen); however, this requires you understand what it should basically be.

Alternatively, once in text mode you can hit the ‘c’ key to be dropped into the grub command-line shell. Here type the following:

find /boot/vmlinuz

Grub should return to you the partition where the kernel is located, in grub notation. So it will look something like “(hd0,0)” or “(hd1,2)” but without the quotes. Once you have this, then do:

root (hdx,y)
kernel /boot/vmlinuz
initrd /boot/initrd
boot

where “(hdx,y)” is what grub returned previously, for example, (hd0,0). That should boot openSUSE. Once in, go to YaST Boot Loader and look at the control file setup. If you aren’t sure what it should be, ask the Boot Loader module to suggest a new configuration (under the Other key, bottom right); check that for accuracy and if OK, click on Finish for the update to be made.

If the above doesn’t work for you, can you boot into Mint, and mount the openSUSE root partition (or the /boot partition, if it is on its own separate partition)? Mint may automatically do this for you in Nautilus. Then in openSUSE use a text editor to open /boot/grub/menu.lst and /boot/grub/device.map and post the contents back here; along with that post the output of (as root): fdisk -l