ignore nice in openSUSE 11.1

Hi, I have an AMD CPU with powernow. I do not want niced processes to be considered when calculating the frequency for powernow because I have things like folding@home running. On openSUSE 10.3 this was default, on openSUSE 11.0 it wasn’t, but I could set it in the file /etc/sysconfig/powersave/scheme_performance changing the CONSIDER_NICE flag to “no”. In openSUSE 11.1 this file has disappeared and I have found no alternative way of ignoring niced processes when calculating frequency.

Any ideas on how to set “ignore nice” in openSUSE 11.1?


Take a look at the file “/opt/kde3/share/config/kpowersaverc” to see if there is a setting in there that fits the bill. Changing the values for “cpuFreqPolicyPerformance” and “cpuFreqDynamicPerformance” to say 100 might help.

Hi RCCrouch,
Thank for the suggestion. It does not fit the bill though, since it does not discriminate between niced processes and other processes, which is what I want. So if I set it to 100 I do not think I will ever get the CPU to scale to full speed no matter how high the process priority is. At least that is how I understand the documentation.